Bug 117658 - system crashes on rhgb/graphical login screen doesn't display
system crashes on rhgb/graphical login screen doesn't display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 12:14 EST by Richard Ayer III
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-26 03:23:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/XF86Config file (3.11 KB, text/plain)
2004-03-07 13:09 EST, Richard Ayer III
no flags Details
/var/log/XFree86.0.log file (57.60 KB, text/plain)
2004-03-07 13:10 EST, Richard Ayer III
no flags Details

  None (edit)
Description Richard Ayer III 2004-03-06 12:14:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Abouta week ago I downloaded kernel version 2.6.3-1.106 as well as
about 500 other updates (I had already downloaded all of the XFree86
updates the day before and had no problems). But now I cannot boot the
system with any version of the kernel. The X server starts up, but the
screen just turns black with the 'X' cursor. Then I press Ctrl-Alt-F1
to get to the login screen, and the system is hanging just after the
step where the swap space is activated/mounted. I now know I can get
around that with the by removing the rhgb flag, and adding the nogui
flag (though it's not really a fix). One other thing: when I
downloaded all of those updates, I did it in two groups; the first
group had the kernel updates, all lib* updates, and I think systembase
(something like that), and the second group was everything else. When
I started up2date for the second group, it couldn't show the little
pictures on the 'forward', 'back', and 'cancel' buttons (the blue
arrows and red X). Then I restarted gkrellm and it said that it could
load some .png files. So I reinstalled libpng (I think version 1.2.5,
which went into /usr/local/lib) and logged out of KDE. The X server
wouldn't start and give me the blue login screen, so I rebooted. Now
after using the nogui flag, rhgb is bypassed, and X tries to start but
can't bring up the login screen; it's says it can't read some .png
file and it just stops there. I can Ctrl-Alt-Fx to another terminal
and login just fine. As of mid-day yesterday, my system is up-to-date
using up2date; the latest kernel I tried with is the 238 version.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rhgb: boot without changing boot parameters
2. X: boot with parameters changed from rhgb to nogui
3.
    

Actual Results:  step 1: system crashes when rhgb tries to start
step 2: X freezes when trying to display the login screen

Expected Results:  rhgb shoud work
X should load and run

Additional info:
Comment 1 Richard Ayer III 2004-03-06 12:37:11 EST
In case it's pertinent, I have an All-In-Wonder Radeon 9800 Pro.
Comment 2 mark 2004-03-06 15:43:59 EST
i'm getting the same problem..

and, when i change rhgb to nogui, X will start loading and then report
that "there was an error loading the theme Bluecurve. couldn't
recognize the image file format for file
"/usr/share/gdm/themes/Bluecurve/icon-language.png"

ati radeon 64MB
fedora 2 test1
kernel 2.6.3-2.1.240
xfree86-4.3.0-62
libpng-1.2.2-19
rhgb-0.11.2-1
Comment 3 mark 2004-03-06 16:09:22 EST
upgrading rhgb to 0.11.2-6 does not fix the problem.
Comment 4 Warren Togami 2004-03-07 03:48:40 EST
Are you absolutely sure this is not the /dev/psaux problem?

Boot into text mode, then look in /etc/X11/XF86Config
If it has "/dev/psaux" anywhere you must change that to
"/dev/input/mouse" then XFree86 should work.  Note that rhgb uses the
same XFree86 as the gdm login screen.  Please try this and report back.

Comment #2 sounds possibly like an unrelated issue.
Comment 5 Richard Ayer III 2004-03-07 13:09:03 EST
Created attachment 98359 [details]
/etc/X11/XF86Config file
Comment 6 Richard Ayer III 2004-03-07 13:09:38 EST
Actually, comment #2 is the same problem I'm having. That's one of the
things I was referring to when taking about the problems with loading
.png files.

I was sure that it's not the /dev/psaux problem; but I booted around
to verify. I have /dev/input/mice in the only 2 places such an entry
would go in my /etc/X11/XF86Config file; I had to fix this several
kernel versions before the current problem came up.
When I booted around just now, I used up2date to get up to kernel 242
and still have the problem. I will attach the /var/log/Xfree86.0.log
file (no reported mouse issues) from that boot, as well as my
/etc/X11/XF86Config file.
Comment 7 Richard Ayer III 2004-03-07 13:10:25 EST
Created attachment 98360 [details]
/var/log/XFree86.0.log file
Comment 8 mark 2004-03-07 16:26:42 EST
this isn't the /dev/psaux problem... my entries all are /dev/input/mice
Comment 9 mark 2004-03-07 16:30:11 EST
i wonder if this line is revelevant:

(WW) Open APM failed (/dev/apm_bios) (No such device)

i have the same exact line as Richard in my XFree86.0.log 
Comment 10 Richard Ayer III 2004-03-19 22:28:13 EST
I just realized that about a week ago this problem suddenly went away,
after a whole lot of updates. So, I have no idea what update actually
fixed the problem, just that it is gone.
Comment 11 mark 2004-03-20 11:47:03 EST
i've continued updating my system with rawhide daily and i am still
struggling with this bug...
Comment 12 Richard Ayer III 2004-03-20 18:23:39 EST
Have you made the switch to the new xorg-x11 yet? The problem was
fixed before this for me, but if you haven't yet.....who knows, it
might work.
Comment 13 Mike A. Harris 2004-03-26 03:18:30 EST
>Then I restarted gkrellm and it said that it could
>load some .png files. So I reinstalled libpng (I think version 1.2.5,
>which went into /usr/local/lib) and logged out of KDE.

Red Hat does not support user supplied versions of core libraries
which are supplied with the operating system.

>The X server wouldn't start and give me the blue login screen, so
>I rebooted.

The X server does not have a login screen.  It is gdm/xdm/kdm which
provides the login screen.

>Now after using the nogui flag, rhgb is bypassed, and X tries to
>start but can't bring up the login screen; it's says it can't read
>some .png file and it just stops there.

Again, the X server does not provide a login screen.  If you are
seeing an error that some .png file can't be read that tells me
two things:

1) The X server is working properly (it does not read .png files
   at all anyway).

2) You are having a problem loading .png files and are using a self
   compiled version of libpng in /usr/local, which is unsupported.



Since Mark in comment #2 is having the same problem, I'll give the
benefit of doubt and consider that the problem is not caused by
your own libpng file for a minute...  From comment #2:

>X will start loading and then report
>that "there was an error loading the theme Bluecurve. couldn't
>recognize the image file format for file
>"/usr/share/gdm/themes/Bluecurve/icon-language.png"

X, as in "the XFree86 X server or software supplied with the
XFree86 package" does not report bugs of that nature.  That is
a problem being reported by something that is part of the GNOME
or KDE desktop startup sequence.

On a side note, from comment #5:

>(--) PCI:*(1:5:0) ATI Technologies Inc unknown chipset (0x4e48) rev
0, Mem @ 0xd0000000/27, 0xe5000000/16, I/O @ 0x9000/8
>(--) PCI: (1:5:1) ATI Technologies Inc unknown chipset (0x4e68) rev
0, Mem @ 0xd8000000/27, 0xe5010000/16

Your Radeon 9800 card is unknown to the X server and unsupported,
but that is not likely part of the problem either.  I see you're
using the 'vesa' driver instead anyway (although it itself is also
unsupported).


From comment #9:

>i wonder if this line is revelevant:
>(WW) Open APM failed (/dev/apm_bios) (No such device)
>i have the same exact line as Richard in my XFree86.0.log 

That is not a bug or problem at all. It indicates that the X server
has attempted to open the apm_bios device to see wether or not
your computer is configured to use APM.  If you do have the computer
using APM, then XFree86 (and xorg-x11) has APM support and will use
APM for power management.  If you do not have APM running and the
APM kernel modules are not loaded, then X will not be able to open
the /dev/apm_bios device because there is no kernel module loaded,
so it gets -ENODEV.  The X server then does not use APM power
management.  It is not an error, but rather an informational message
in case you really did want APM support to work, and have just
misconfigured your kernel.   A lot of people misreport this as
a bug or error, so perhaps I should update that warning message
to be more informative.  ;o)

I've filed bug reports about that separately:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119195
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119196


Comment 14 Mike A. Harris 2004-03-26 03:23:37 EST
Closing bug as RAWHIDE as per comment #10 above from original
reporter.  My last comment, I just wanted to address each
of the previous comments to make the report complete.

Thanks guys.
Comment 15 Martin Hylerstedt 2004-09-22 09:21:04 EDT
I also experienced this BlueCurve "Couldn't recognize the image file 
format" error after running up2date. The error wasn't a bug, so to 
speak, more of a post-install problem/misconfiguration. libpng works, 
Gnome works, BlueCurve works, it's just a matter of telling gtk how 
to handle images. For some reason this had disappeared but at 
http://www.linuxquestions.org/questions/showthread.php?postid=793209 
I found a solution.

Run:
/usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

and

/usr/bin/gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

and reboot, no more icon-language.png problem.

Note You need to log in before you can comment on or make changes to this bug.