Bug 117678 - Installer fails to create /boot partition after converting from ext2 to ext3 - OS won't boot
Summary: Installer fails to create /boot partition after converting from ext2 to ext3 ...
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-07 00:45 UTC by David Costanzo
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 19:07:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Costanzo 2004-03-07 00:45:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
I recently tried to upgrade a RH 7.1 machine to Fedora Core 2 Test 1.
 Somewhere along the lines, the upgrade was botched, because after it
was all done, I did not have a legimate /boot parition.  Instead, I
had a /boot directory with a single file in it: kernel.h.

During the upgrade process, the installer suggested that I upgrade my
/boot and /swap paritions from ext2 to ext3.  I didn't see why a boot
parition needed to be ext3, but I chose to upgrade it anyway.  I did
not get an error message, but it's possible that the upgrade didn't go
well.

After the installation, my machine didn't boot up.  It did give me a
bash shell.  Running df showed that there was no boot parition. 
Running ls showed a /boot directory with a single file in it: kernel.h.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Install RH 7.1.  Format a boot parition in ext2
2.Upgrade to Fedora Core 2 Test 1.
3.


Actual Results:  The system wouldn't boot because it couldn't find a
kernel

Expected Results:  The system boots into FC2.

Additional info:

I tried re-doing the upgrade but that didn't fix anything.  

I have since installed FC 2, test 1 without upgrading, so I won't be
able to do any forensics.  This bug is not a problem for me, I am
simply reporting it out of a sense of civic duty.


Note You need to log in before you can comment on or make changes to this bug.