Bug 117680 - htb patch missing from latest iproute errata
htb patch missing from latest iproute errata
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: iproute (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 21:20 EST by Vince Skahan
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 09:17:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vince Skahan 2004-03-06 21:20:09 EST
Description of problem:

Looks like the htb3-tc patch that was previously present in iproute 
is missing from the latest iproute errata update.

If you do a "rpm -q --changelog" versus the previous version (iproute-
2.4.7-7), you see:
 
* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ 
(#75486).

* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
- remove flags patch at author's request

Yet if you query the changelog for the errata update (iproute-2.4.7-
7.90.1), notice that there is no mention of the scheduler patch:

* Mon Nov 03 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7.90.1
- Security errata for netlink (CAN-2003-0856).

* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
- remove flags patch at author's request

We need the scheduler patch put back in, and a bug errata update 
released before RedHat 9 leaves support please.

Version-Release number of selected component (if applicable):
iproute-2.4.7-7.90.1.i386.rpm

How reproducible:
always

Steps to Reproduce:
1.run "tc qdisc add dev eth0 root handle 1: htb default 50"
  
Actual results:
The command above returns:
   Unknown qdisc "htb", hence option "default" is unparsable

Expected results:
The command should run successfully.

Additional info:
The previous version of iproute works fine, looks like you just 
missed including the patch somehow in the latest errata update.

There are quite a few Google references with multiple people finding 
this was broken in the errata update.

A quick check of Google says that the latest Fedora iproute is 
supposedly working ok, but I don't know whether running this later 
version vs. RedHat9 causes other problems or not.  Best to fix the 
RedHat9 errata.
Comment 1 Phil Knirsch 2004-03-08 09:14:47 EST
Hm, thats really strange. But as the other people have reported, using
the FC1 version should work nicely with Red Hat Linux 9.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.