This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117711 - dasd_mod.ko: unknown symbol delete_partition
dasd_mod.ko: unknown symbol delete_partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-07 15:53 EST by Oliver Paukstadt
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 21:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Quick and Dirty patch to make it run (354 bytes, patch)
2004-03-07 15:55 EST, Oliver Paukstadt
no flags Details | Diff
The fix (1.58 KB, patch)
2004-03-15 14:52 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Oliver Paukstadt 2004-03-07 15:53:31 EST
Description of problem:
WARNING:
/lib/modules/2.6.3-2.1.240/kernel/drivers/s390/block/dasd_mod.ko needs
unknown symbol delete_partition

Version-Release number of selected component (if applicable):
2.6.3-2.1.240

How reproducible:
insmod fails every time because of unresolved symbol.

Additional info:
Quick and Dirty patch attached.
The clean patch might be a fix in dasd_mod using an ioctl instead of a
direct call.
Comment 1 Oliver Paukstadt 2004-03-07 15:55:13 EST
Created attachment 98361 [details]
Quick and Dirty patch to make it run
Comment 2 Karsten Hopp 2004-03-08 09:09:21 EST
Pete already had a correct fix for this in CVS version 1.5 of our 
linux-2.6.1-s390-compile.patch. Please re-add it so that I can start 
working on mainframe installer issues with kernel-2.6 
Comment 3 Oliver Paukstadt 2004-03-13 06:40:05 EST
kernel-2.6.3-2.1.253 still broken
Comment 4 Pete Zaitcev 2004-03-15 14:52:40 EST
Created attachment 98552 [details]
The fix
Comment 5 Pete Zaitcev 2004-03-15 14:56:02 EST
Modified in 2.6.4-2.1.277.
Comment 6 Oliver Paukstadt 2004-03-15 15:28:41 EST
Does not compile on top of kernel-2.6.3-2.1.253 because of BDEV_RAW.
Waiting for 2.6.4-2.1.277.
Comment 7 Pete Zaitcev 2004-03-15 17:55:09 EST
Correct, it's a patch for 2.6.1. I removed the extra arguments
and replaced flags '1' with '0'.

Note You need to log in before you can comment on or make changes to this bug.