Bug 11773 - initrd loading fails if client has 1GB+ RAM
Summary: initrd loading fails if client has 1GB+ RAM
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pxe   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
: 11774 11775 27203 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-31 08:31 UTC by Istvan Marko
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-31 19:45:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Istvan Marko 2000-05-31 19:42:33 UTC
sorry about the multiple reports, bugzilla was bugging out on me (sent a report
to bugzilla@redhat.com)

Looks like the body of the report still didn''t make it, let me try it here:

When trying to do a remote linux installation on a machine with 1GB of RAM
using the PXE setup that ships with RH 6.2 I get the following message:

...
Warning only 960 MB will be used
initrd extends beyond end of memory (0xffef0000 > 0xfc000000)
disabling initrd
...

not surprisingly the initrd is not mounted and the installation cannot
proceed.

the following patch to pxe-linux/nbp.linux/download.c seems to fix this for
me but I don''t know enough about initrd and PXE to be sure that this is
correct:

--- nbp.linux/download.c.orig	Thu Sep 23 17:58:21 1999
+++ nbp.linux/download.c	Wed May 31 00:57:35 2000
@@ -94,7 +94,7 @@
 	t_PXE_MTFTP_SPORT *mtftp_sport;
 	t_PXE_MTFTP_TMOUT *mtftp_tmout;
 	t_PXE_MTFTP_DELAY *mtftp_delay;
-
+	unsigned long mem;
 	if (bootfile = find_dhcp_tag(&reply, 67, 0)) {
 		strncpy(dl_fname, bootfile->buf, bootfile->len);
 		dl_fname[bootfile->len] = 0;
@@ -115,8 +115,11 @@
 	}
 
 	initrd_size = 4 * 1024L * 1024L;
-
-	initrd_addr = (get_memsize() - 1024L) * 1024L - initrd_size;
+	mem=get_memsize();
+	if (mem>960*1024L) {
+		mem=960*1024L;
+	}
+	initrd_addr = (mem - 1024L) * 1024L - initrd_size;
 
 	cll();
 	bputs("Downloading initrd image...'\n");



On a normal LILO boot (after the installation is complete) I don''t get the
above message, instead I get the following and initrd seems to work OK:
...
63MB BIGMEM available.
relocating initrd image:
    initrd_start:0xc0fa3000    initrd_end:0xc0fff612
    mem_start:0xc026c000    mem_end:0xfc000000
    initrd_size:0x0005c612     dest:0xfbfa3000
...


Comment 1 Istvan Marko 2000-05-31 19:44:04 UTC
*** Bug 11774 has been marked as a duplicate of this bug. ***

Comment 2 Istvan Marko 2000-05-31 19:45:48 UTC
*** Bug 11775 has been marked as a duplicate of this bug. ***

Comment 3 Erik Troan 2000-07-13 16:31:12 UTC
The bets solution is really to use the pxelinux PXE loader, which is packaged in
rawhide.

Comment 4 Elliot Lee 2001-08-26 20:11:04 UTC
*** Bug 27203 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.