Bug 117740 - cisco vpn software client fails to build with Bus Errors
cisco vpn software client fails to build with Bus Errors
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc3 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-07 20:01 EST by Donald E. Foss
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 05:15:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed output file from cc1 that it asked me to attach (417.20 KB, text/plain)
2004-03-07 20:04 EST, Donald E. Foss
no flags Details

  None (edit)
Description Donald E. Foss 2004-03-07 20:01:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The cisco software vpn client fails to build.  This worked a couple of
kernals ago.  The cisco client software version is
vpnclient-linux-4.0.3.B-k9.  I get the following when I run vpn_install:

Making module
linuxcniapi.c: In function `os_alloc':
linuxcniapi.c:37: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccV5NcQw.out file, please attach
this to your bugreport
interceptor.c: In function `interceptor_init':
interceptor.c:114: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccLyoSDz.out file, please attach
this to your bugreport
IPSecDrvOS_linux.c: In function `UpdateTimeZoneOffset':
IPSecDrvOS_linux.c:39: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccX1zls2.out file, please attach
this to your bugreport
frag.c: In function `queue_fragment':
frag.c:102: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccm344mG.out file, please attach
this to your bugreport




Version-Release number of selected component (if applicable):
gcc-3.2.3-24

How reproducible:
Always

Steps to Reproduce:
1. unpack vpn client software to /tmp
2. cd vpn_client directory
3. execute vpn_install
    

Actual Results:  Making module
linuxcniapi.c: In function `os_alloc':
linuxcniapi.c:37: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccV5NcQw.out file, please attach
this to your bugreport
interceptor.c: In function `interceptor_init':
interceptor.c:114: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccLyoSDz.out file, please attach
this to your bugreport
IPSecDrvOS_linux.c: In function `UpdateTimeZoneOffset':
IPSecDrvOS_linux.c:39: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccX1zls2.out file, please attach
this to your bugreport
frag.c: In function `queue_fragment':
frag.c:102: internal error: Bus error
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into /tmp/ccm344mG.out file, please attach
this to your bugreport

Expected Results:  proper making <g>.  The client should have built
and installed correctly.

Additional info:
Comment 1 Donald E. Foss 2004-03-07 20:04:08 EST
Created attachment 98363 [details]
preprocessed output file from cc1 that it asked me to attach

c++ source code
Comment 2 Donald E. Foss 2004-03-07 20:05:13 EST
I attached one of the output files.  I can attach the rest if you
want, but I haven't yet.  Just let me know.
Comment 3 Donald E. Foss 2004-03-07 20:08:33 EST
I checked and found that I already have the latest version of the
cisco client software.
Comment 4 Jakub Jelinek 2004-03-08 07:37:01 EST
What exact gcc version you're using?
I certainly cannot reproduce this with gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-30).
Comment 5 Donald E. Foss 2004-03-08 21:21:42 EST
I found that the problem was a hard drive going bad.  I tried it again
before submitting the gcc version and looked at /var/log/messages and
found the uncorrectable drive errors.

Thanks for checking into it and I'm glad its not a real problem with gcc.

Please close this bug report.

Note You need to log in before you can comment on or make changes to this bug.