Bug 117765 - tcl src.rpm XFree86 dependancy
tcl src.rpm XFree86 dependancy
Status: CLOSED DUPLICATE of bug 116771
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 06:56 EST by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-03-08 06:56:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
The specfile for tcl uses the mkdirhier command. This is provided by
XFree86 package. Therefore you cannot build tcl, which is a
commandline language, unless you have XFree86 installed. This
dependancy is not noted in the Build Requires, either.

The solution is to replace mkdirhier with 'mkdir -p'. This simple
substitution fixes tcl so that it compiles without Xfree86 installed.

Version-Release number of selected component (if applicable):
tcl-8.4.5-5

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb /usr/src/redhat/SPEC/tcl.spec
    

Actual Results:  no rpm package produced

Expected Results:  rpm package produced

Additional info:
Comment 1 Jens Petersen 2004-03-08 19:49:07 EST

*** This bug has been marked as a duplicate of 116771 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.