This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117777 - USB printer not immediately autodetected and configured
USB printer not immediately autodetected and configured
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal-cups-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 08:49 EST by Stewart Smith
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 16:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stewart Smith 2004-03-08 08:49:29 EST
Description of problem:
Printer is only configured on reboot, not when immediately plugged in.

Version-Release number of selected component (if applicable):
Fedora Core 2 test1

How reproducible:
All the time

Steps to Reproduce:
1. Install Fedora
2. Plug in printer
3. get annoyed and reboot hoping it'll configure itself.
  
Actual results:
Have to reboot to have printer configured

Expected results:
It "just work"

Additional info:

Canon S400 USB printer.
Comment 1 Dave 2004-03-18 04:23:37 EST
I have the same problem with a Epson C40 PLus. 
Comment 2 W. Michael Petullo 2004-09-15 22:03:21 EDT
Bug #132388 documents similar problems with a USB Brother HL1440
printed.  Bug #132388's report contains things like the output from
lshal and hal_lpadmin.  I don't know if the problem is caused by the
same things but I thought the additional data might help.
Comment 3 Tim Waugh 2004-10-11 08:22:38 EDT
I think this belongs to hal-cups-utils (not sure).
Comment 4 John (J5) Palmieri 2004-10-11 09:17:36 EDT
Dave and Stewart.  Have you tried the latest Rawhide?  If it still
doesn't work please post the output of lshal.

This should all be fixed in rawhide and in fact Michael's has been
marked a resolved.
Comment 5 John (J5) Palmieri 2004-10-14 16:14:12 EDT
Closing for now.  Please reopen if you still see these problems

Note You need to log in before you can comment on or make changes to this bug.