Bug 117778 - With US-English keymap/keyboard, right CNTL-ALT-Fn doesn't switch to VC#n
With US-English keymap/keyboard, right CNTL-ALT-Fn doesn't switch to VC#n
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 08:49 EST by Glen A. Foster
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 10:25:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2004-03-08 08:49:58 EST
INTRO: I have no idea if kbdconfig is the right component for this
report -- please forward accordingly if I filed it wrong.  Also, this
bug is a nit... with a non-English keymap where the right ALT key is
used to generate other characters (like ones in the Romanian character
set), this is not a bug at all.  But the US English keymap doesn't
have any such characters... and with that background:

Description of problem: 

You can use the RIGHT Control-and-Alt keys with Function-key 1 through
6 in X to switch to a different Virtual Console (VC).  But once you're
in, say, VC1, you cannot use the RIGHT Control-and-Alt keys with
function keys to switch to any other console, including the VGA (VC7).
 From VC1-through-VC6, you _must_ use the LEFT Control-and-Alt keys in
conjunction with F2-through-F7 to navigate to another console.  Since
the US English keymap doesn't use the right Control-and-Alt keys, this
is a bit inflexible.  The workaround, of course, is to use the left
Cotrol-and-Alt keys, but it's a bug nonetheless.

Version-Release number of selected component (if applicable):
I'm running on RHL 8.0, updated via RHN.  I have no idea if this is
the right component, but:

# rpm -q kbdconfig-1.9.16-1

How reproducible: 100% (always)

Steps to Reproduce:
1. Start X, use RIGHT_control + RIGHT_alt + F1 to move to VC1
2. use RIGHT_control + RIGHT_alt + F7 to try to get to VGA
3. use LEFT_control + LEFT_alt + F7 to actually get to VGA
Comment 1 Eido Inoue 2004-03-09 14:12:57 EST
8.0 is no longer supported, but it does appear in later versions
(current 3.0E and FC1) as well.
Comment 2 Miloslav Trmač 2005-02-18 10:25:43 EST
Actually, AltGr (right alt) _is_ special in the us keymap;
try AltGr-{7,8,9,0,-} and, after (loadkeys -u us), AltGr-{5,c}.

I don't think this change should be done at the distribution level;
if upstream keymaps change, we will change too.

Note You need to log in before you can comment on or make changes to this bug.