Bug 117801 - Bootloader install (silently) does not install if no other packages updated
Bootloader install (silently) does not install if no other packages updated
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 13:54 EST by Rick Wagner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 17:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rick Wagner 2004-03-08 13:54:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040130

Description of problem:
After an upgrade from RH9, had an unbootable situation, where GRUB was
failing to load.  After much poking and proding in rescue mode,
decided to re-upgrade.  Rebooted the install disk, selected upgrade. 
Install found my now FC-1 configuration.  I selected to install the
boot loader (not just upgrade).  The install flew through all three
CDs, since nothing needed to install.

Rebooted, and still had same GRUB hang.  Later retried the same
procedure, watching the text screens.  Saw a the end a message
basically saying that sinde no packages were upgraded, the bootloader
would not be installed.

Into rescue mode, and downgraded one package (kernel I think).  Reboot
installer, follwed same procedure; this time the kernel was upgraded,
and a message that the bootloader was installed.  Reboot, and system
comes up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run upgrade on a system that is already up to date.
2. Select "Install boot loader"

    

Actual Results:  Boot loader not installed (verified on text console,
and failre to boot).  No message on install screen that the boot
loader was not installed.

Expected Results:  Boot load should have been installed (best).  Or at
least a message at the end saying it was not, and why (doesn't help,
but at least you'd know).

Additional info:
Comment 1 Jeremy Katz 2004-05-06 17:15:04 EDT
We can't install the boot loader if there's not a kernel (not enough
information on how to create the boot loader config, etc) and that's
why the message pops up saying that there are no kernels being
installed and thus the boot loader won't be.

Note You need to log in before you can comment on or make changes to this bug.