Bug 117835 - mailman 2.1.4 update compiled against Python 2.3?
mailman 2.1.4 update compiled against Python 2.3?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 22:19 EST by James Henstridge
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-03 16:39:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Henstridge 2004-03-08 22:19:57 EST
Description of problem:
Since upgrading to the 2.1.4-1 package released as an FC1 update, I
get the following email from Cron each day:

From: root@daa.com.au (Cron Daemon)
To: mailman@daa.com.au
Subject: Cron <mailman@quoll> /usr/bin/python -S
/var/mailman/cron/checkdbs

/var/mailman/pythonlib/japanese/c/iso_2022_jp.py:4: RuntimeWarning:
Python C API version mismatch for module _japanese_codecs: This Python
has API version 1011, module _japanese_codecs has version 1012.
  import codecs, japanese.c._japanese_codecs

Judging by the Python headers, API version 1011 corresponds to Python
2.2.x, and 1012 to 2.3.x.

Additionally, running "rpm --verify mailman" shows that all the byte
compiled .pyc have changed, which I assume is because the .pyc files
distributed with the package were 2.3 byte code.

Version-Release number of selected component (if applicable):
mailman-2.1.4-1

How reproducible:
Every time.

Steps to Reproduce:
1.Install FC1
2.Install mailman-2.1.4-1 update
  
Actual results:
Warning raised when japanese codec imported
All bytecode overwritten on first run.

Expected results:
Package should have been compiled against Python 2.2

Additional info:
Other than the warnings, Mailman appears to be functioning correctly.
 It would be nice to get rid of the warnings though.
Comment 1 John Dennis 2004-09-03 16:39:23 EDT
After a bit of investigation I'm sorry to say I can't explain the
version mismatch. It appears as though somehow when the
mailman-2.1.4-1 package was built in our build system it picked up a
2.3 python when it should have been a 2.2. Mysterious to me. The
lastest FC1 update for mailman is mailman-2.1.5-6 which I just checked
and the module appears to be correctly built against 2.2. 

I don't think this is causing you any trouble and the latest update
seems fine so I'm going to close this with the recommendation that if
you want to get rid of the warning upgrading to the latest mailman
package should work.

Note You need to log in before you can comment on or make changes to this bug.