Bug 117911 - QGEN: oql Error in SimpleQueueManager
Summary: QGEN: oql Error in SimpleQueueManager
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: persistence   
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 113496
TreeView+ depends on / blocked
 
Reported: 2004-03-09 22:13 UTC by Jon Orris
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 18:48:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Orris 2004-03-09 22:13:57 UTC
Description of problem:
@41196/oracle-se

The notification.SimpleQueueManager is failing with an oql error when
fetching a QueueItem
2004-03-09 17:03:22,991 [ead-3] INFO  notification.SimpleQueueManager
- processing current requests
2004-03-09 17:03:22,992 [ead-3] INFO  rdbms.RDBMSEngine - Executing
this = sql {com.arsdigita.notification.GetSim\pleQueuedNotifications}
2004-03-09 17:03:22,993 [ead-3] INFO  rdbms.RDBMSEngine - select
t1.request_id as "this_requestID0",
       t1.message_id as "this_messageID1",
       t1.party_to as "this_partyTo2"
from (
        select q.request_id,
               q.party_to,
               p.primary_email,
               r.message_id
        from   nt_queue q,
               nt_requests r,
               parties p
        where  q.request_id = r.request_id
          and  r.status='queued'
          and  p.party_id = q.party_to
          and  r.digest_id is null
          and  q.success_p = '0'
          and  q.retry_count <= r.max_retries) t1
2004-03-09 17:03:22,993 [ead-3] INFO  rdbms.RDBMSEngine - []
2004-03-09 17:03:22,993 [ead-3] INFO  rdbms.RDBMSEngine - []
2004-03-09 17:03:22,993 [ead-3] INFO  rdbms.RDBMSEngine - {}
2004-03-09 17:03:22,996 [ead-4] INFO  notification.RequestManager -
processing current requests.
2004-03-09 17:03:23,011 [ead-5] INFO  rdbms.RDBMSEngine - Executing
this = sql {com.arsdigita.search.intermedia.g\etJobInfo}
2004-03-09 17:03:23,014 [ead-3] INFO  rdbms.RDBMSEngine - Executing
filter(all(com.arsdigita.notification.QueueIt\em), (requestID == 560)
and (partyTo == 268))
2004-03-09 17:03:23,015 [ead-5] INFO  rdbms.RDBMSEngine - select
t1.job_num as "this_jobNum0",
       t1.job_status as "this_jobStatus1"
from (
        select search_indexing.job_number() as job_num,
               search_indexing.get_status() as job_status
        from dual) t1
2004-03-09 17:03:23,015 [ead-5] INFO  rdbms.RDBMSEngine - []
2004-03-09 17:03:23,016 [ead-5] INFO  rdbms.RDBMSEngine - []
2004-03-09 17:03:23,016 [ead-5] INFO  rdbms.RDBMSEngine - {}
2004-03-09 17:03:23,031 [ead-3] ERROR notification.SimpleQueueManager
- An unexpeced error occured in the queue m\anager. This queue has
been disabled.
java.lang.IllegalArgumentException: length of arrays differs
    at com.redhat.persistence.oql.Code.sort(Code.java:317)
    at com.redhat.persistence.oql.Code.cols(Code.java:273)
    at com.redhat.persistence.oql.Code.columns(Code.java:263)
    at
com.redhat.persistence.oql.Get$PropertyCondition.conditions(Get.java:329)
    at
com.redhat.persistence.oql.Get$PropertyCondition.access$000(Get.java:135)
    at com.redhat.persistence.oql.Get$1.onValue(Get.java:313)
    at com.redhat.persistence.metadata.Value.dispatch(Value.java:47)
    at
com.redhat.persistence.oql.Get$PropertyCondition.conditions(Get.java:311)
    at
com.redhat.persistence.oql.Get$PropertyCondition.<init>(Get.java:148)
    at com.redhat.persistence.oql.Get.frame(Get.java:109)
    at com.redhat.persistence.oql.Variable.frame(Variable.java:26)
    at com.redhat.persistence.oql.Query.generate(Query.java:59)
    at
com.redhat.persistence.engine.rdbms.OracleWriter.write(OracleWriter.java:34)
    at com.redhat.persistence.engine.rdbms.Select.write(Select.java:60)
    at
com.redhat.persistence.engine.rdbms.SQLWriter.write(SQLWriter.java:169)
    at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:436)
    at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:430)
    at
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:265)
    at com.redhat.persistence.Cursor.execute(Cursor.java:131)
    at com.redhat.persistence.Cursor.next(Cursor.java:115)
    at com.redhat.persistence.Session.retrieve(Session.java:123)
    at com.arsdigita.persistence.Session.retrieve(Session.java:343)
    at com.arsdigita.domain.DomainObject.<init>(DomainObject.java:128)
    at
com.arsdigita.domain.ObservableDomainObject.<init>(ObservableDomainObject.java:100)
    at com.arsdigita.notification.QueueItem.<init>(QueueItem.java:70)
    at
com.arsdigita.notification.SimpleQueueManager.run(SimpleQueueManager.java:81)

Comment 1 Jon Orris 2004-03-11 00:11:18 UTC
After Archit's change @41231, get the following error:
2004-03-10 19:09:07,152 [ead-3] ERROR notification.SimpleQueueManager
- Unexpected error occured. SimpleQueueManager has been disabled.
com.arsdigita.persistence.PersistenceException (root cause:
com.redhat.persistence.metadata.MetadataException:
com/arsdigita/notification/Notification.pdl: line 27, column 15: Query
for: com.arsdigita.notification.QueueItem.partyToAddr failed to return
rows)
        at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:100)
        at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:86)
        at
com.arsdigita.persistence.DataObjectImpl.get(DataObjectImpl.java:529)
        at
com.arsdigita.persistence.DataObjectImpl.get(DataObjectImpl.java:232)
        at com.arsdigita.domain.DomainObject.get(DomainObject.java:436)
        at com.arsdigita.notification.QueueItem.getTo(QueueItem.java:109)
        at
com.arsdigita.notification.SimpleQueueManager.run(SimpleQueueManager.java:100)
        at java.util.TimerThread.mainLoop(Timer.java:432)
        at java.util.TimerThread.run(Timer.java:382)
Root cause:
com.redhat.persistence.metadata.MetadataException:
com/arsdigita/notification/Notification.pdl: line 27, column 15: Query
for: com.arsdigita.notification.QueueItem.partyToAddr failed to return
rows
        at
com.redhat.persistence.Session.fetchPropertyData(Session.java:985)
        at com.redhat.persistence.Session$1.onRole(Session.java:147)
        at com.redhat.persistence.metadata.Role.dispatch(Role.java:92)
        at com.redhat.persistence.Session.get(Session.java:145)
        at
com.arsdigita.persistence.DataObjectImpl.get(DataObjectImpl.java:527)
        at
com.arsdigita.persistence.DataObjectImpl.get(DataObjectImpl.java:232)
        at com.arsdigita.domain.DomainObject.get(DomainObject.java:436)
        at com.arsdigita.notification.QueueItem.getTo(QueueItem.java:109)
        at
com.arsdigita.notification.SimpleQueueManager.run(SimpleQueueManager.java:100)



Comment 2 Jon Orris 2004-03-11 18:04:58 UTC
Naturally, I cannot reproduce this bug. I'm leaving in ON_QA for the
time being, and will see if it crops up on a different db, or after
the test qgen land.



Comment 3 Jon Orris 2004-03-17 18:48:20 UTC
Haven't been able to reproduce at all. Closing



Note You need to log in before you can comment on or make changes to this bug.