Bug 117915 - addition of aspell-el in Fedora Core
addition of aspell-el in Fedora Core
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 18:08 EST by Nikos Charonitakis
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 13:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Charonitakis 2004-03-09 18:08:41 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
can you add el (Greek) dictionary of aspell in distro?
its licence is gpl  
(for aspell-ispell)
http://ispell.source.gr/licence.html

additional comments from Simos Xenitellis:
Indeed the Greek speller should be available through the normal channels
(ispell/aspell projects pages), as per:

- Availability in ispell WWW page:
http://fmg-www.cs.ucla.edu/geoff/ispell-dictionaries.html#Greek-dicts

- Availability in asplell WWW page:
http://ftp.gnu.org/gnu/aspell/dict/  (Look under Greek)

additional comments by Steve Stavropoulos:
 I have created a src.rpm to include in "fedora linux" which you can
find at
http://master.math.upatras.gr/~steve/aspell-el-0.004.tar.bz2 (rpmbuilt
-ts will
create the src.rpm)
 It is the same with the one in http://ispell.source.gr and
http://ftp.gnu.org/gnu/aspell/dict/ with only a few bugfixes and a
name change
from aspell-greek to aspell-el. (I had packaged/codeveloped the previous
releases too)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nikos Charonitakis 2004-03-09 18:09:05 EST
steve@math.upatras.gr
Comment 2 Simos Xenitellis 2004-03-27 10:25:20 EST
This is an issue that should be resolved in FC2.
I believe the links provided contain all the information needed to add
the package.

Simos Xenitellis,
Free Translation Project
GNOME Localisation Project
Comment 3 Dimitris 2004-03-27 14:09:22 EST
Greek support should be improved in general. redhat 8, 9 and FC1
did not have the required fonts to be able to write Greek properly,
we had opened several bug reports on this and redhat told us to go....

anyway, their excuse was that they didn't have Greek fonts, and they
wouldn't go out of their way to install any. We have been told to
do it by hand.

spellchecking for Greek should finaly be included in FC2, since all
the required files have been available for some years now. Next, we
should get some proper Greek fonts out-of-the-box. Then we can
talk about translations (Greek has 35% translations only in FC).
Comment 4 Simos Xenitellis 2004-03-28 12:07:34 EST
Indeed there is a shortage of quality fonts with Greek glyphs,
distributed under a proper open-source license.

There is the situation however a user would install Greek fonts after
the installation or proper fonts will be available in the near future.

For the second case, Bitstream Vera will have Greek (monotonic)
support by mid-2004.

In addition, the "Free Outline UCS fonts"
(http://savannah.nongnu.org/projects/freefont/) support Greek.

I see that the dictionary should be included in Fedora as it is made
available in other GNOME distributions like Ximian GNOME.

Note You need to log in before you can comment on or make changes to this bug.