Bug 117986 - rndc and rndc-confgen need to have same default understanding of key
rndc and rndc-confgen need to have same default understanding of key
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
: 122496 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-10 15:07 EST by Tom Wood
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 12:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2004-03-10 15:07:03 EST
Description of problem:rndc and rndc-confgen, by default, don't use
the same nomenclature for the key name ("rndc-key" vs. "rndc.key"). 
This makes them incompatible without hand edits.


Version-Release number of selected component (if
applicable):bind-9.2.3-8.1



How reproducible: Every time


Steps to Reproduce:
1. Run "rndc-confgen -a" for automatic configuration.
2. Configure bind so that it will start (any valid config will do).
3. Run "service named start".
4. Run "rndc status" and watch it spew forth "rndc: no key definition
for name rndckey"
  
Actual results: Error message as above

Expected results: rndc should have been able to find the key as per
the manpage for rndc-confgen.

Additional info:  Editing /etc/rndc.key and changing the options and
server references to "rndc-key" instead of "rndc.key" fixes the
problem.  Be sure not to change the include line, however.
Comment 1 Daniel Walsh 2004-03-25 13:18:02 EST
Fixed in bind--9.2.3-11.src.rpm
Comment 2 Jeremy Katz 2004-05-06 18:32:59 EDT
*** Bug 122496 has been marked as a duplicate of this bug. ***
Comment 3 Tom Wood 2004-05-10 17:08:44 EDT
Good to go.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.