Bug 118035 - system-config-samba fails to add user and dismiss dialog
system-config-samba fails to add user and dismiss dialog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 06:17 EST by Andrew Farris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 10:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2004-03-11 06:17:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
When attempting to "Add User" while viewing the "Samba Users" listbox
the dialog displays, accepts data in the fields, but will not dismiss
and create the user entry with the "Ok" button.  The dialog can be
canceled or closed by window manager but no user is added.
---------

Traceback (most recent call last):
  File "/usr/share/system-config-samba/addUserWin.py", line 172, in
on_add_user_ok_button_clicked
    elif self.samba_user_data.userAlreadyExists(unix_name):
  File "/usr/share/system-config-samba/sambaUserData.py", line 201, in
userAlreadyExists
    if user == tokens[0]:
IndexError: list index out of range


Version-Release number of selected component (if applicable):
system-config-samba-1.2.5-1

How reproducible:
Always

Steps to Reproduce:
1. Open system-config-samba
2. Select menu "Preferences" -> "Samba Users"
3. Select "Add User" and enter username (new user or a duplicate
creates the same error
4. Click OK to add the user, traceback results
    

Actual Results:  User is not added to the samba users list, dialog is
not dismissed

Expected Results:  User should be added to list and dialog dismissed

Additional info:

python-2.3.3-2.1
pygtk2-2.0.0-5.1
libuser-0.51.7-7.1.1
htmlview-2.0.0-12
samba-3.0.2a-1.1
usermode-1.69-5
Comment 1 Brent Fox 2004-03-11 10:26:56 EST
This bug was caused due to blank lines in the smbusers file which was
not expected.  Should be fixed in system-config-samba-1.2.6-1 in
Rawhide.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.