This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 118042 - libxml2-python-2.6.6-3 installs in python-2.2 if python-2.3 installed
libxml2-python-2.6.6-3 installs in python-2.2 if python-2.3 installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 07:57 EST by Christian Ashby
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 04:29:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Ashby 2004-03-11 07:57:12 EST
Description of problem:

Latest version of up2date will not fuction due to incorrect
libxml2-python installation path

Version-Release number of selected component (if applicable):

libxml2-python-2.6.6-3
python-2.3.3-1

How reproducible:

Very

Steps to Reproduce:
1. Install libxml2-python-2.6.6-3
2.
3.
  
Actual results:

As below:
csca2@albatross:~$ rpm -ql libxml2-python
/usr/lib/python2.2/site-packages/drv_libxml2.py
/usr/lib/python2.2/site-packages/libxml2.py
/usr/lib/python2.2/site-packages/libxml2mod.a
/usr/lib/python2.2/site-packages/libxml2mod.la
/usr/lib/python2.2/site-packages/libxml2mod.so


Expected results:

csca2@albatross:~$ rpm -ql libxml2-python
/usr/lib/python2.3/site-packages/drv_libxml2.py
/usr/lib/python2.3/site-packages/libxml2.py
/usr/lib/python2.3/site-packages/libxml2mod.a
/usr/lib/python2.3/site-packages/libxml2mod.la
/usr/lib/python2.3/site-packages/libxml2mod.so

Additional info:

Can fix by copying python2.2/site-packages to python2.3
Comment 1 Daniel Veillard 2004-03-11 08:09:33 EST
The install path for the python module will depend on the
version of python libxml2 was built against. The package you
installed was built against Python-2.2 . You have Python 2.3
installed. The simplest is to rebuild the libxml2 package
from source. Dynamically trying to install in 2.3 if compiled
agaisnt 2.2 is just a good way to break the installation in
a nasty way, this should not be done.

Daniel
Comment 2 Christian Ashby 2004-03-11 08:14:35 EST
Apologies, I may not have assigned this to the correct module; I've
therefore reassigned to distribution as the versions of libxml2 and
python(2.3) installed with the FC2-test1 distribution are compiled as
I described, and so up2date is broken after an upgrade from FC1.

I'm well aware that the installation path shouldn't be copied across,
it was just a quick fix to get up2date back up and running again.
Comment 3 Warren Togami 2004-04-19 04:24:21 EDT
libxml2-2.6.9-1 coming soon in rawhide solves this issue, it is built
against FC2 latest.
Comment 4 Warren Togami 2004-04-19 04:29:12 EDT
oops, I was wrong, libxml2-2.6.8 already fixed this.

Note You need to log in before you can comment on or make changes to this bug.