Bug 118115 - raid1 rootfs: 2.6.3 kernels panic at boot on Proliant DL360 P21
raid1 rootfs: 2.6.3 kernels panic at boot on Proliant DL360 P21
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 21:19 EST by Christopher Johnson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 22:18:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Serial console capture of 2.6 kernel boot process including panic (7.88 KB, text/plain)
2004-03-11 21:21 EST, Christopher Johnson
no flags Details

  None (edit)
Description Christopher Johnson 2004-03-11 21:19:18 EST
Description of problem:
Started with FC1, not 1.90. And the 2.4 kernels still boot fine.  But
2.6 kernels I have added fail to boot. pci=noacpi and acpi=off help it
get further so it successfully recognizes and binds partitions to the
raid1 devices, but it fails to mount the ext3 root filesystem
contained within.  That causes pivot_root to fail, and init to not be
found, resulting in a panic.  Boot messages captured on a serial
console are attached.

Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253 i686

How reproducible:
Always

Steps to Reproduce:
1. Boot 2.6.3 i686 kernel from rawhide rpms on DL360 P21
2.
3.
    

Actual Results:  Kernel panic

Expected Results:  Normal boot like 2.4 kernels do.

Additional info:

This is 1GHz P4 processor with two SCSI drives, all partitions (except
swap) mirrored across the drives using software raid 1.  The hardware
raid controller board has been removed from the SCSI controller, thus
is not a factor.

The P21 BIOS has been flashed to 11/15/2002 (the latest).
Comment 1 Christopher Johnson 2004-03-11 21:21:40 EST
Created attachment 98478 [details]
Serial console capture of 2.6 kernel boot process including panic
Comment 2 Christopher Johnson 2004-03-22 22:18:44 EST
Problem solved!
I upgraded mkinitrd and modutils packages from rawhide and installed
packages device-mapper and lvm2 to resolve dependencies.
Then I made a new initrd and rebooted.  Using FC1's mkinitrd and/or
modutils was the cause of the 2.6 boot problem.

Note You need to log in before you can comment on or make changes to this bug.