Bug 118117 - mozilla autodetect CJK character coding
Summary: mozilla autodetect CJK character coding
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-12 04:00 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 22:22:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2004-03-12 04:00:48 UTC
Description of problem:
With a default Japanese install, when one visits
badly configured sites with mozilla in a ja locale
it displays garbage text rather than Japanese,
since it defaulting to Latin1 encoding

How reproducible:
everytime

Steps to Reproduce:
1. http://www.tv-asahi.co.jp/asanama/video/
  
Actual results:
ÆtÆZÆCÆâųâÃ¥âÂâÃâÃÂgâ¢Â¿ÂSâ©âÃÆjÆâ¦Â[ÆXâÃÂAâDÂÃâ°Â»â

Expected results:
Japanese text

Additional info:
Would it be possible to turn on autodetect for CJK languages
by default when mozilla is running in a CJK locale? :)

Comment 1 Christopher Blizzard 2004-03-12 22:22:56 UTC
That code is already on.  We try to do autodection, no matter what
language you are in.  Of course, it's a guess so sometimes it gets it
wrong.


Note You need to log in before you can comment on or make changes to this bug.