Bug 118121 - wxPython fails to build against gtk2-2.3.6-1
wxPython fails to build against gtk2-2.3.6-1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-12 00:45 EST by Ellen Shull
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 09:55:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ellen Shull 2004-03-12 00:45:50 EST
Description of problem: 
 
# rpmbuild --rebuild wxPythonGTK2-py2.3-2.4.2.4-1.src.rpm 
[happily compiles away for several minutes, then...] 
+ c++ -L/usr/src/redhat/BUILD/wxPythonSrc-2.4.2.4/build/lib -pthread 
-Wl,-rpath -Wl,/usr/lib/wxPython-2.4.2.4/lib -lwx_gtk2ud-2.4 wxrc.o 
xml.o xmlparse.o xmlres.o xmlrole.o xmltok.o -o wxrc 
/usr/src/redhat/BUILD/wxPythonSrc-2.4.2.4/build/lib/libwx_gtk2ud-2.4.so: 
undefined reference to `_gtk_accel_group_detach' 
/usr/src/redhat/BUILD/wxPythonSrc-2.4.2.4/build/lib/libwx_gtk2ud-2.4.so: 
undefined reference to `_gtk_accel_group_attach' 
/usr/src/redhat/BUILD/wxPythonSrc-2.4.2.4/build/lib/libwx_gtk2ud-2.4.so: 
undefined reference to `_gtk_rc_context_get_default_font_name' 
collect2: ld returned 1 exit status 
 
Honestly, I don't know if this is a problem in the gtk2 package, or 
an api change in gtk2 that means wxPython needs to be modified, or 
what...  just wanted to bring it to the attention of someone who 
might know. 
 
Version-Release number of selected component (if applicable): 
* wxPythonGTK2-py2.3-2.4.2.4-1.src.rpm from 
http://wxpython.sourceforge.net/download.php#sources 
* gtk2-2.3.6-1 from fedora rawhide 
* building with gcc-3.3.3-2.1, rpm-4.3-0.19, etc from fedora rawhide 
 
How reproducible: 
always
Comment 1 Ellen Shull 2004-03-12 01:40:06 EST
Forgot to mention that wxPython did successfully build against an  
earlier rawhide gtk2, don't remember exactly but probably the  
gtk2-2.3.2-2.i386.rpm that was in the FC2T1 release. 
Comment 2 Owen Taylor 2004-03-12 09:55:23 EST
Looks like the wxGtk sources are accessing internal private
GTK+ symbols like _gtk_accel_group_detach.

there was a bug in a couple of versions of GTK+ where we
accidentally exported these symbols on Linux, but it's never been
legal to access them.

From the GTK+ README file:

* The GTK+ libraries use an '_' prefix to indicate private symbols that
  must not be used by applications. On some platforms, symbols beginning
  with prefixes such as _gtk, _gdk, and _pango will be exported
  from the library, on others not. In no case can applications
  use these private symbols.

Note You need to log in before you can comment on or make changes to this bug.