Bug 11813 - KDE Hangs on shutdown
KDE Hangs on shutdown
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-31 23:06 EDT by David Frager
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-13 19:34:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Frager 2000-05-31 23:06:49 EDT
I have just installed Redhat 6.2 on my system, with KDE as my desktop.  If
I have been running Netscape 4.72 during the session, KDE will hang when I
attempt to shutdown.  When I select shutdown, a splash box comes up stating
processing sessions, then the system hangs.

Additionally, when If I do not have netscape running during a session and
shutdown, the KDE login screen appears, I select shutdown/restart, the KDE
login screen appears again, then when I select shutdown/restart again, the
system shutsdown properly.
Comment 1 Aleksey Nogin 2000-06-02 18:24:01 EDT
I am having the same problems. I have them both in RedHat 6.2 and RedHat 6.1. I
haven't tested it thoroughly, but I belive this is more likely to happen if I
have more than one Netscape window opened.
Comment 2 Aleksey Nogin 2000-06-02 18:33:00 EDT
See also bug #7071. BTW, I am using netscape-communicator-4.73-1, but I had the
same problem with previous versions of communicator. Also, I usually have a
browser window and a Mail&Newsgroup window open. Hope that helps.
Comment 3 Bernhard Rosenkraenzer 2000-06-18 09:48:45 EDT
I can't reproduce this...
If it is Netscape related, there's nothing we can do about it in any case - we
don't have access to the source for that.
Comment 4 Aleksey Nogin 2000-06-18 10:16:51 EDT
I disagree with "here's nothing we can do about it". Even if it happens because
of Netscape, it's still KDE's fault - it should time out instead of waiting for
Netscape's response forever. If you are interested, I am willing to do more
testing and give you more specific instructions on reproducing the problem. On
my machines (all of them!) it's almost 100%-reporoducable.

P.S. I had the same problems on RedHat 6.1

P.P.S. Can somebody mark this as reopened, please?
Comment 5 Andreas Metzler 2000-06-19 04:18:36 EDT
Hello!
The original submitter talked about two different bugs: 
-netscape blocks logout from kde logout
-shutdown with kdm does not work properly.

All comments where about bug#1, I can reproduce the second one, too and
it is even more annoying - sometimes you end in something like 
runlevel 3 (runlevel 5 minus kdm) instead of halt.

Should I repost this as a separate bug?
       cu andreas
Comment 6 David Frager 2000-06-21 18:34:43 EDT
I just saw the "resolution".  I can easily reproduce both of there senerios in
either a networked, or dial-up environment.  I agree with the other comments,
this bug is not resolved.
Comment 7 Aleksey Nogin 2000-06-21 19:04:40 EDT
To ametzler: we were talking about the first bug here. The second one was
reported numerous times and (I believe) was fixed in Rawhide.

To dfrager: you should be able to mark the bug as reopened (only the original
reporter or RedHat people can change the bug status). Can you do that? Thanks!
Comment 8 Aleksey Nogin 2000-06-21 19:57:04 EDT
P.S. The KDE shutdown bug is described in bug #10662, bug #11028 and bug #11598.
The first one is marked as fixed in Rawhide.
Comment 9 David Frager 2000-09-15 10:47:17 EDT
Looks like Netscape 4.75 solves this problem for Redhat 6.2
Comment 10 Aleksey Nogin 2000-09-15 13:16:55 EDT
No, not really. Im am using Communicator 4.75 and with 100% reproducability on 3
different machines (3 desktops and a laptop) I have the following:

1) If I have a single Navigator window opened, everything works fine.

2) If I have a Navigator window and a Mail&News window and I try to quit KDE, it
dims the screen, prints a message that it's preparing for quitting (I do not
remebre what is the English analog of the message I get in Russian) and hangs.
Comment 11 Aleksey Nogin 2000-12-13 19:34:50 EST
After I've upgraded to Communicator 4.76, I still have this problem. This
problem is really nasty since accidentally hitting the "X" on the panel (for
example, instead of the lock screen button next to it) causes all the unsaved
work to be lost since KDE never gets to the stage where it would ask whether to
proceed with exiting, or to cancel it...
Comment 12 Bernhard Rosenkraenzer 2001-05-17 06:28:27 EDT
Looks like a netscape problem after all. Since we don't have the source, 
there's nothing we can do to fix it, other than recommending to use Konqueror 
or Mozilla rather than Netscape.


Note You need to log in before you can comment on or make changes to this bug.