Bug 118146 - missing texinfo BuildPreReq
missing texinfo BuildPreReq
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: grub (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-12 09:13 EST by Felipe Alfaro Solana
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version: 0.95-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 20:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2004-03-12 09:13:09 EST
Description of problem:
-----------------------
The .spec file for grub-0.94-3.src.rpm is missing the "texinfo" build
prerequisite. When rebuilding grub from the SRPM file, if "texinfo" is
not installed, the grub.info.gz file is not correctly created.
Instead, a zero-length file is left in its place.

This is caused by the %prep stage invoking "makeinfo" to build the
info file. "makeinfo" belongs to the "texinfo" package, thus the
"texinfo" build prerequisite.

Version-Release number of selected component (if applicable):
0.94-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -e texinfo
2. rpmbuild --rebuild grub-0.94-3.src.rpm
3. rpm -i <resulting grub-0.94-3.i386.rpm>

The resulting RPM has a zero-bytes grub.info.gz file.
  
Actual results:
The .spec file for grub doesn't list "texinfo" as a build
prerequisite. During %prep stake, "makeinfo" external program is
called which depends on "texinfo" being installed.

Expected results:
The .spec file for grub should list "texinfo" as a build prerequisite.

Additional info:
Comment 1 Jeremy Katz 2004-03-12 12:06:39 EST
Added to CVS, will be in next build.
Comment 2 Felipe Alfaro Solana 2004-09-28 20:10:41 EDT
Fix confirmed for grub-0.95-2

Note You need to log in before you can comment on or make changes to this bug.