Bug 118175 - 4 * printf problems
4 * printf problems
Status: CLOSED DUPLICATE of bug 116355
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-12 14:48 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-03-12 14:48:12 EST
Description of problem:

I just tried to compile Fedora Core2 Test1 package exim-4.30-5

The compiler said

1.

pipe.c(835): warning #268: the format string ends before this argument

The source code is

    addr->message = string_sprintf("pipe delivery process timed out",
      tblock->name);

No % specifiers, but one trailing parameter.

2.

smtp.c(1497): warning #268: the format string ends before this argument

Source code is

  message = US string_sprintf("send() to %s [%s] failed",
    host->name, host->address, strerror(save_errno));

Two % specifiers, three trailing parameters.

3.

smtp.c(1644): warning #268: the format string ends before this argument

Duplicate.

4.

smtp_out.c(110): warning #267: the format string requires additional
arguments

The source code is

  addr->message = string_sprintf("failed to expand \"%s\" (\"port\"
option) "
    "for %s: %s", msg, expand_string_message);

Three % specifiers, but only two trailing parameters. A certain
run time problem.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-07-02 08:56:01 EDT

*** This bug has been marked as a duplicate of 116355 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.