Bug 118228 - RFE: include the epoch in the default query format to avoid confusing novices
RFE: include the epoch in the default query format to avoid confusing novices
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-13 19:09 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 08:39:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-03-13 19:09:29 EST
Currently RPM "hides" epoch numbers of packages, creating user
confusion and increasing resistance against using the epoch numbers.
Would it be a
good idea to change the default query format to include the epoch number?

P.S. And may be the arch as well - this is, of course, unrelated, but
if we are willing to endure the QA "costs" related to such change, it
might be reasonable to get the maximum "mileage" out of it.
Comment 1 R P Herrold 2004-03-13 19:22:28 EST
If inclined to alter the macro to emit Epoch information, it would
lessen the interpertation burden, if it only showed when non-null (not
that I believe this -- there was an rpm-ba vs rpmbuild Bugzilla on
what is coming up on 4 years after the cutover yesterday)

But also there is the issue that there is a body of parsing code out
there which will be broken by the sudden appearance of the [1-9]*: in
front of the VR
Comment 2 Aleksey Nogin 2004-03-13 22:09:16 EST
> But also there is the issue that there is a body of parsing code out
> there which will be broken by the sudden appearance of the [1-9]*: in
> front of the VR.

Yes, this is what I was thinking about when I was talking about the QA
costs of such a change.
Comment 3 Jos Vos 2004-03-14 05:42:07 EST
Maybe it's an idea to change at least the information displayed with
rpm  -qi, if the change of rpm -q is considered too problematic.
Comment 4 Jeff Johnson 2004-03-14 09:18:48 EST
You can configure whatever you wish to display as the
default format using
    %_query_all_fmt         %%{name}-%%{version}-%%{release}
in particular epoch and arch can be added.
Comment 5 Aleksey Nogin 2004-03-14 17:44:01 EST
> You can configure whatever you wish to display as the default format

This is not the point - yes, expert users can change the way thing
slook, but the epert users are not the problem - novices are. It is
becoming clear that the current implementation of the epoch number can
be very confusing, especially for novices. And the reason that it is
so confusing is that rpm pays a lot of attention to the epoch numbers,
but almost never "reveals" it.

I fully realize that changing something so basic would be a an
extremely drastic step and will have a lot of consequences, but IMHO
this is still something that needs to be considered and evaluated.
Please, if at all possible, do not be too quick to dismiss this right
away.

P.S. I agree with comment #3 - adding it to the rpm -qi seems like a
good first step.
Comment 6 Jeff Johnson 2004-03-15 08:39:56 EST
Novices have no idea what an Epoch: is, and displaying the
Epoch: in rpm -qi is not going to change "no idea".

Note You need to log in before you can comment on or make changes to this bug.