Bug 118242 - iconv and groff fail when using man command
Summary: iconv and groff fail when using man command
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-14 13:14 UTC by Eric N. Ebert
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 05:53:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric N. Ebert 2004-03-14 13:14:34 UTC
Description of problem:
When doing man login, man logout, and man rpm icov and groff report
broken pipes when I hit q to quit the man page.

Version-Release number of selected component (if applicable):
glibc-2.3.3-16
groff-1.18.1-34

How reproducible:
Always

Steps to Reproduce:
1.man login
2.Hit q to quit the man page
3.
  
Actual results:
Error is returned in the shell


Expected results:
Man should quit normally

Additional info:
/usr/bin/nroff: line 69: 21648 Done                    /usr/bin/iconv
-f ${charset_in} -t utf-8 ${TMPFILE}
     21649                       | /usr/bin/groff -mtty-char -Tutf8
$opts 2>/dev/null
     21650 Broken pipe             | /usr/bin/iconv -f utf-8 -t
${charset_out}//translit

Comment 1 Jakub Jelinek 2004-05-27 12:53:17 UTC
What $LANG (or $LC_ALL) do you use?
I cannot reproduce this on FC2 with en_US.UTF-8.

Comment 2 Ulrich Drepper 2004-08-26 05:53:50 UTC
No reply in three months.  Closing.


Note You need to log in before you can comment on or make changes to this bug.