Bug 118248 - up2date-4.3.11-2.1.1 with rpm-4.3-0.20 requires GLIBC 2.3.4
up2date-4.3.11-2.1.1 with rpm-4.3-0.20 requires GLIBC 2.3.4
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-14 10:18 EST by Dave H
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 21:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave H 2004-03-14 10:18:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
When attempting to run up2date, I get an error message: 

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 12, in ?
    import rpm
ImportError: /usr/lib/librpmio-4.3.so: symbol regexec, version
GLIBC_2.3.4 not defined in file libc.so.6 with link time reference

GLIBC_2.3.4 is not available and rpm-4.3-0.19 is not available either.



Version-Release number of selected component (if applicable):
up2date-4.3.11-2.1.1, rpm-4.3-0.20, glibc-2.3.3-13

How reproducible:
Always

Steps to Reproduce:
1. run up2date
2.
3.
    

Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/up2date", line 12, in ?
    import rpm
ImportError: /usr/lib/librpmio-4.3.so: symbol regexec, version
GLIBC_2.3.4 not defined in file libc.so.6 with link time reference

Expected Results:  Ability to up2date properly

Additional info:

To save on downloading problems with versioning of various packages, I
usually start with a letter and update them, for example, just the
r*rpm packages.  I let up2date pick the dependencies if there are any
and don't get the packages that don't seem to have matching dependencies.

At the time I had updated on 3/13/04 from z back to r.
Comment 1 Daniel Malmgren 2004-03-15 13:49:33 EST
This bug has broken yum as well.
Comment 2 Jeff Johnson 2004-03-15 18:07:44 EST
What does "rpm -V --nofiles rpm rpm-python" say when you
reach the state above?
Comment 3 Dave H 2004-03-15 23:18:10 EST
I do not get any output from that command, just back to the prompt,
whether root or a user.

Do you want a package listing?

glibc-2.3.3-13
glibc-common-2.3.3-13
glibc-debug-2.3.3-13
glibc-devel-2.3.3-13
glibc-headers-2.3.3-13
glibc-kernheaders-2.4-8.43
glibc-profile-2.3.3-13
glibc-utils-2.3.3-13
python-2.3.3-2
python-devel-2.3.3-2
python-docs-2.3.3-2
python-optik-1.4.1-5
python-tools-2.3.3-2
rpm-4.3-0.20
rpm-build-4.3-0.20
rpmdb-fedora-1.90-0.20040312
rpm-devel-4.3-0.20
rpm-python-4.3-0.20
Comment 4 Jeff Johnson 2004-03-16 08:28:54 EST
This dependency chain should have associated the needed
glibc symbol with librpmio used by rpm-python:

$ rpm -q --requires rpm-python | grep rpmio
librpmio-4.3.so
$ rpm -q --provides rpm | grep rpmio
librpmio-4.3.so
$ rpm -q --requires rpm | grep 2.3.4
libc.so.6(GLIBC_2.3.4)
$ rpm -q --provides glibc | grep 2.3.4
libc.so.6(GLIBC_2.3.4)

Somehow rpm was updated w/o glibc being updated.

The "rpm -V --nofiles rpm rpm-python" command verified
that that dependency chain was actually in place.

I suspect that your up2date is functioning now. Is that the case?

Comment 5 Dave H 2004-03-16 09:24:45 EST
Ran those 4 commands and got those responses but up2date does not work
yet.
Comment 6 Jeff Johnson 2004-03-16 09:43:48 EST
Off to up2date for diagnosis then. All I can thinkof
is that up2date is using a different rpmmodule.so somehow.

You might want do do
    rpm -V rpm rpm-python glibc
to insure that all the files are as expected.
Comment 7 Dave H 2004-03-16 20:39:44 EST
As far as I can tell, rpm is working fine.  I can update, install and
remove from the command line.

Did not get any output from the above command though.
Comment 8 Dave H 2004-03-17 21:08:48 EST
Updated to the latest rpm and glibc and the problem is fixed.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.