Bug 118258 - Colour is not reset on SIG INT
Colour is not reset on SIG INT
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: coreutils (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-14 12:33 EST by Need Real Name
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 12:37:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-03-14 12:33:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Red Hat has:
 $ alias ls
 alias ls='ls --color=tty'

When I run ls on a directory containing a large number of files, and
press Ctrl+C, ls exits, but does not reset the colour for the terminal.

For example, if ls is half way through printing a green executable
file, and I kill ls, everything I type afterwards is now in green.

How reproducible:
Always
Comment 1 Need Real Name 2004-04-23 09:50:24 EDT
Should ls do this, or is this more of a bash "feature"?
Comment 2 Tim Waugh 2004-04-29 12:05:25 EDT
This is an ls bug, yes.  There have been some changes upstream which
should fix this, but I doubt they will get into Fedora Core 2 before
release at this point.  Deferring until the next round.
Comment 3 Tim Waugh 2004-11-02 12:37:10 EST
I think this is fixed now (5.2.1-31) -- at least, I can't reproduce
it.  Please re-open if you still see this problem.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.