Bug 118300 - bootloader.py fails during upgrade, kernelLabel is not defined
bootloader.py fails during upgrade, kernelLabel is not defined
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: 118232 118360 122153 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-03-15 06:55 EST by Jonathan Wakely
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-15 12:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2004-03-15 06:55:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4) Gecko/20030703

Description of problem:
At the time this happened my system wasn't entirely usable, and I was
upgrading (partly) in order to make the MBR point at linux again (a
windows xp setup had overwritten it), so I wasn't too concerned with
recording the error and this bug report is from memory, my apologies.

While upgrading from FC 0.96 x86_64 to FC1 x86_64 final, bootloader.py
failed on the following line, complaining that kernelLabel was undefined.

  kernelList.append((kernelLabel, kernelLongLabel, version))

Dropping into the python debugger "print kernelLabel" and "print
kernelLongLabel" showed they were both undefined. IIRC version was
defined OK.

Before the upgrade to FC1 final I had installed the 2174 kernel
released as an update to the 0.96 test release, and _I_think_ my
grub.conf included both the original 2135 kernel from the 0.96 release
and the 2174 update kernel (although it might have only had the 2174
update). The MBR had been overwritten by WinXP though, so I couldn't
boot any linux kernel.

After rebooting from the CD in rescue mode I did a manual grub-install
and it worked fine. At this point grub.conf had only one item, the
2174 kernel.

Version-Release number of selected component (if applicable):
The version on the FC1 x86_64 CDs.

How reproducible:
Didn't try

Steps to Reproduce:
This is what I did when the bug happened, I haven't tried to reproduce
it since.
1. Install Fedora Core 0.96 for x86_64
2. Install 2174 update kernel.
3. Upgrade to FC1 for x86_64.

Actual Results:  After installing packages bootloader.py script fails
to setup bootloader.

Expected Results:  Boot loader installs and installation continues.

Additional info:
Comment 1 Jonathan Wakely 2004-03-15 06:56:54 EST
I forgot to mention, this was during a text-mode install/upgrade (my
video card isn't recognised by FC1)
Comment 2 Brent Fox 2004-03-15 10:32:05 EST
*** Bug 118232 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2004-03-15 11:27:13 EST
Upgrades from a beta/test release to a final release are not
supported.  If you attach the complete traceback, I can take a look at
it, though (without the complete traceback, there's not much I can
really do, though other than guessing randomly)
Comment 4 Sam Varshavchik 2004-03-15 20:13:56 EST
There's a complete traceback attached to bug 118232.
Comment 5 Jonathan Wakely 2004-03-17 04:20:45 EST
I realise the upgrade path I took was unsupported, but I thought I'd
log the bug anyway as I didn't know whether it was a direct result of
upgrading from the test release or not.

The traceback on bug 118232 does look like the same error as mine,
thanks mrsam. My package selection was different, of course. Now that
I've got the box playing nicely I'll check tonight whether the install
log has some more useful information.
Comment 6 Jeremy Katz 2004-05-06 17:41:21 EDT
*** Bug 118360 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2004-05-06 18:12:14 EDT
*** Bug 122153 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2004-05-06 21:27:45 EDT
Haven't reproduced but put a fix that should fix this in CVS

Note You need to log in before you can comment on or make changes to this bug.