This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 118303 - unable to delete users in adminstration section
unable to delete users in adminstration section
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-15 08:39 EST by martin black
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 08:48:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description martin black 2004-03-15 08:39:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
In Administration I am unable to delete a user.  When I 
click 'delete' I get 'User Delete Failed'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.search for user 'david'
2. click name link
3. click delete user
    

Actual Results:  I get 'User Delete Failed'

Expected Results:  I should be able to delete user

Additional info:

In this case the user has left the council so there is a security 
risk, thus I want to get him off the system.  He has published items 
in the past.  I can get around this by changing his password but I'd 
rather delete him complelety.
Comment 1 Daniel Berrange 2004-03-15 08:48:31 EST
As a general rule it is impossible to delete a user if they have ever
created any objects (eg, content) within the system, since the user
information is required for auditing purposes. The solution is to
login as admin & change their password so they can no longer access
the system.

Note You need to log in before you can comment on or make changes to this bug.