Bug 118331 - gnome-panel crashes when Run Application selected in DISPLAY=1:1 with multi-head display
gnome-panel crashes when Run Application selected in DISPLAY=1:1 with multi-h...
Status: CLOSED DUPLICATE of bug 109172
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-15 11:50 EST by Scott R. Godin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott R. Godin 2004-03-15 11:50:57 EST
Description of problem:
Multi-head display set to non-spanning desktops
Gnome menu on DISPLAY 1:1 does not duplicate icon settings from
original display, when first created (and it should prefer user prefs
over the default, if changes have been made, IMHO)
mousing to 2nd display and choosing Run Application causes BOTH panels
to crash and restart.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.2-3

How reproducible:
every time

Steps to Reproduce:
1. Set up multi-head for X
2. start a new gnome-session
3. mouse to 2nd display and choose "Run Application.." from the gnome
menu on the panel
  
Actual results:
crash of both gnome-panels

Expected results:
run application dialog should appear

Additional info:
Comment 1 Scott R. Godin 2004-03-15 12:18:39 EST
additional info is gleaned from a quick look at ~/.xsession-errors

Unable to open desktop file
applications:///Accessories/redhat-print.desktop for panel launcher:
Error reading file 'applications:///Accesso
ries/redhat-print.desktop': File not found
The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 25913 error_code 8 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
Window manager warning: Working around an application which called
XSetInputFocus (None) or with RevertToNone instead of RevertToPointerRoot
, this is a minor bug in some application. If you can figure out which
application causes this please report it as a bug against that applic
ation.
Window manager warning: Working around an application which called
XSetInputFocus (None) or with RevertToNone instead of RevertToPointerRoot
, this is a minor bug in some application. If you can figure out which
application causes this please report it as a bug against that applic
ation.
Comment 2 Adam Israel 2004-03-25 16:36:39 EST
I'm running into the same problem as Scott.

~/.xsession-errors

The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 3793 error_code 8 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
 
(eggcups:4576): Gdk-WARNING **: GdkWindow 0x1600003 unexpectedly destroyed
 
(pam-panel-icon:4593): Gdk-WARNING **: GdkWindow 0x2400003
unexpectedly destroyedWindow manager warning: Working around an
application which called XSetInputFocus (None) or with RevertToNone
instead of RevertToPointerRoot, this is a minor bug
in some application. If you can figure out which application causes
this please report it as a bug against that application.
Window manager warning: Working around an application which called
XSetInputFocus (None) or with RevertToNone instead of
RevertToPointerRoot, this is a minor bug
in some application. If you can figure out which application causes
this please report it as a bug against that application.
 
(rhn-applet:4596): Gdk-WARNING **: GdkWindow 0x280002a unexpectedly
destroyed
 
(rhn-applet:4596): Gdk-WARNING **: GdkWindow 0x2800003 unexpectedly
destroyed
Comment 3 Mark McLoughlin 2004-03-26 03:09:40 EST

*** This bug has been marked as a duplicate of 109172 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.