Bug 118391 - named reload fails with "out of memory" error.
named reload fails with "out of memory" error.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 06:19 EST by Rob Andrews
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 07:58:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Andrews 2004-03-16 06:19:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040116 Galeon/1.3.13

Description of problem:
Firstly, a bit of background.

We run a Very Large Nameserver(tm). The specification of the box alone
is a dual Intel P4 Xeon 2GHz, hyperthreading enabled so appears as 4
CPUs, 4GB of memory and 9GB of swap space. We thought this would be...
more than capable of doing it's job, given it's predecessor running
bind 8. But we're encountering one very big problem.

The nameserver has 567,849 zones in it's configuration file. Once
loaded (a lengthy process), it consumes around 1.7GB of memory. After
a few hours of running, the usage goes up to around 2.7GB. Originally,
the box was equipped with 1GB of memory and a measly amount of swap,
so we went out and purchased a further 3GB of memory to compensate.

At first, we started with a bog standard 2.4.22-1.2174.nptlsmp kernel
(i686 build). Aware that the memory limit for this kernel is 4GB, we
grabbed the source RPM and edited the spec to build a bigmem
(HIGHMEM64G) kernel with 64GB limit. Enabled the swap space and restarted.

No matter what happens now, with both 2.4.22-1.2174.nptlsmp and
2.4.22-1.2174.nptlbigmem, whenever we issue "rndc reload", leave the
box about 10 minutes and we get:

Mar 16 06:37:15 <hostname> named[961]: reloading configuration failed:
out of memory

...which we get the feeling shouldn't happen with 13GB of available
combined memory and swap.

We're getting around the issue at the moment by once per day stopping
the named process completely and starting it again.

Is there something we've missed? Should it be failing to reload?

Any insights you have would be very gratefully received :)

Version-Release number of selected component (if applicable):
bind-9.2.2.P3-9

How reproducible:
Always

Steps to Reproduce:
1. Start nameserver completely.
2. Leave to run for 2-3 hours.
3. Issues 'rndc reload' from root shell and watch /var/log/messages
for "out of memory" message.

Actual Results:  named process continues to run but with old
configuration and zone data.

Expected Results:  It should have reloaded the configuration, new
zones and updated zones.

Additional info:

Kernel packages used:

kernel-smp-2.4.22-1.2174.nptl
kernel-bigmem-2.4.22-1.2174.nptl
Comment 1 Rob Andrews 2004-03-19 07:57:39 EST
davej informs me that this is most likely due to the per-process
memory limit, namely 1G kernel/3G process. So as such this isn't a
problem with bind.

I should most likely close this then. Sorry to trouble you!

Note You need to log in before you can comment on or make changes to this bug.