Bug 118454 - Kudzu rpm turns kudzu back on upon update
Summary: Kudzu rpm turns kudzu back on upon update
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-16 20:20 UTC by Michael A. Peters
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 20:28:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael A. Peters 2004-03-16 20:20:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
If a user has turned of kudzu in the boot scripts ( chkconfig --del
kudzu ) - updating kudzu will turn it back on.

This is problematic for people who have kudzu turned off at boot for a
reason. I have two such machines -

1) A headless CVS server. Kudzu delays boot because it detects
hardware (the keyboard) has been removed, and there's no way to tell
it to ignore (since it boots w/o keyboard)

2) A fedora box booting to runlevel 5 with the Fedora kernel and the
nVidia closed source kernel driver.

In both those cases - I want kudzu, can run it after boot if I've
added hardware I want configured. In both those cases, I do not want
kudzu running at boot time.

The rpm %post script should only add the kudzu symlinks if kudzu has
not previously been installed. If it has previously been installed, it
should keep the run level symlinks the way the sysadmin has them
before the update.

Version-Release number of selected component (if applicable):
1.1.52-1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora
2. chkconfig -del kudzu
3. yum -y update kudzu
    

Actual Results:  kudzu runs at boot

Expected Results:  kudzu does not run at boot

Additional info:

simple spec file change

Comment 1 Bill Nottingham 2004-03-16 20:28:55 UTC
To disable:

chkconfig --level 345 kudzu off

Not:

chkconfig --del kudzu

Comment 2 Michael A. Peters 2004-03-17 01:13:34 UTC
From the man page for chkconfig -

--del name
              The  service  is removed from chkconfig management, and
any sym-
              bolic links in /etc/rc[0-6].d which pertain to it are
removed.

-
How is that not a proper way to disable kudzu?

Comment 3 Bill Nottingham 2004-03-17 03:09:04 UTC
Because, as you said, services run chkconfig --add in their %post
script; this is standard behavior for any service under Red Hat/Fedora.

Some clarification has been added to the chkconfig man page in CVS, it
will be in future chkconfig builds (after 1.3.9-1).

Comment 4 Michael A. Peters 2004-03-17 04:17:58 UTC
%post
if [ $1 = 1 ]; then
    /sbin/chkconfig --add kudzu
fi

%preun
if [ $1 = 0 ]; then
    /sbin/chkconfig --del kudzu
fi

-=-
That would (I think - been awhile since I wrote spec files) only add
kudzu to the chkconfig managed init scripts in a fresh install of
kudzu. In an upgrade - it would undo what a system administrator has
chosen to do with respect to kudzu and chkconfig.

Comment 5 Michael A. Peters 2004-03-17 04:18:40 UTC
it would undo = it wouldn't undo

Comment 6 Bill Nottingham 2004-03-17 04:24:11 UTC
This change won't be made to this one package. It's standard behavior
across *ALL* packages.


Note You need to log in before you can comment on or make changes to this bug.