Bug 1185007 - *** BUG *** In pixman_region32_init_rect: Invalid rectangle passed
Summary: *** BUG *** In pixman_region32_init_rect: Invalid rectangle passed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-22 17:01 UTC by Pete Zaitcev
Modified: 2015-04-02 15:34 UTC (History)
2 users (show)

Fixed In Version: poppler-0.26.2-9.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-02 15:34:31 UTC


Attachments (Terms of Use)
reproducer document (451.54 KB, application/pdf)
2015-01-22 17:01 UTC, Pete Zaitcev
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 16619 None None None Never

Description Pete Zaitcev 2015-01-22 17:01:23 UTC
Created attachment 982955 [details]
reproducer document

Description of problem:

While displaying a certain file, the following appears on the console:

[zaitcev@guren ~]$ evince tmp/flight_review.pdf
*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

[zaitcev@guren ~]$ 

Evince itself does not crash and displays the document.

Version-Release number of selected component (if applicable):

evince-3.14.1-7.fc21.x86_64

How reproducible:

Synchronous, on every invocation (not only on the first one).
Specific to the document (see attachment).

Steps to Reproduce:
1. Donwload attached document
2. evince flight_review.pdf

Actual results:

Message

Expected results:

No message

Additional info:

I understand it may be a broken document, however I would prefer
not to see that message. Hopefuly this is fixable.

Comment 1 Marek Kašík 2015-03-26 16:33:47 UTC
Hi,

the problem is that on the page 17 is a rotated text for which are wrong bounding boxes computed. I've prepared a patch for poppler which fixes the problem. It can be found here: https://bugs.freedesktop.org/show_bug.cgi?id=16619.
I've pushed it into Fedora 21, Fedora 22 and rawhide.

Comment 2 Fedora Update System 2015-03-26 16:37:31 UTC
poppler-0.26.2-9.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/poppler-0.26.2-9.fc21

Comment 3 Fedora Update System 2015-03-26 16:38:42 UTC
poppler-0.30.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/poppler-0.30.0-3.fc22

Comment 4 lnie 2015-03-27 02:58:36 UTC
poppler-0.26.2-9.fc21 works

Comment 5 Pete Zaitcev 2015-03-27 18:25:18 UTC
Verified working on F21 (both the bug and for basic regressions). There was some kind of QA hang-up, so I pulled from Koji.

Comment 6 Fedora Update System 2015-03-29 04:30:33 UTC
Package poppler-0.26.2-9.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing poppler-0.26.2-9.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4823/poppler-0.26.2-9.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-03-31 21:57:06 UTC
poppler-0.30.0-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-04-02 15:34:31 UTC
poppler-0.26.2-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.