Bug 118513 - undefined code
undefined code
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-17 04:46 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 01:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-03-17 04:46:27 EST
Description of problem:

I just tried to compile Fedora Core2 Test1 package
gdb-6.0post-0.20031117.7

The compiler said

/usr/src/redhat/BUILD/gdb+dejagnu-20031117/gdb/dwarf2-frame.c:1328:
warning: operation on `buf' may be undefined

The source code is

          buf += size_of_encoded_value (*buf++);

I agree with the compiler - this code is certainly undefined.
Maybe

          buf += 1 + size_of_encoded_value (*buf);

was intended by the programmer ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Binderman 2004-11-16 11:12:44 EST
I can confirm that this bug still exists in Fedora Core 3,
some eight months later.

Seems a bit pointless to ask for bug reports and then
do nothing about them.
Comment 2 John Thacker 2006-04-22 01:15:59 EDT
This kind of bug is best filed upstream.

Note You need to log in before you can comment on or make changes to this bug.