Bug 118580 - patch: net-snmp 5.1.1 (rc1)
Summary: patch: net-snmp 5.1.1 (rc1)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-17 21:38 UTC by Kaj J. Niemi
Modified: 2015-03-05 01:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 14:45:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated -pie patch for net-snmp 5.1.1, note change in name reflecting minor version (1.20 KB, patch)
2004-03-17 21:38 UTC, Kaj J. Niemi
no flags Details | Diff
Updated memory buffers patch, note change in name reflecting minor version (2.38 KB, patch)
2004-03-17 21:44 UTC, Kaj J. Niemi
no flags Details | Diff
diff to net-snmp.spec version 5.1-11.1, might as well attach it now (1.75 KB, patch)
2004-03-17 21:53 UTC, Kaj J. Niemi
no flags Details | Diff
Trivial backport of the 5.1.1rc1 hr_storage.c patch for net-snmp 5.1. (2.28 KB, patch)
2004-03-18 17:13 UTC, Kaj J. Niemi
no flags Details | Diff

Description Kaj J. Niemi 2004-03-17 21:38:07 UTC
Description of problem:

Attached are updated patches to get net-snmp 5.1.1 rc1 (and I guess
5.1.1 when it is released around Friday or so?) working.

I'll attach a diff to previous fc-devel spec when the final release is
out :)

Changelog so far:

- Patch #10 (net-snmp-5.1-getopt.patch) is unnecessary (fixed upstream)
- Updated Patch #13 (net-snmp-5.1.1-hr_storage-mbuf-v2.patch)
- Updated Patch #14 (net-snmp-5.1.1-pie.patch)

Thanks.

Comment 1 Kaj J. Niemi 2004-03-17 21:38:53 UTC
Created attachment 98617 [details]
Updated -pie patch for net-snmp 5.1.1, note change in name reflecting minor version

Comment 2 Kaj J. Niemi 2004-03-17 21:44:32 UTC
Created attachment 98618 [details]
Updated memory buffers patch, note change in name reflecting minor version

Updated memory buffers patch, I rewrote it to match how the upstream function
now looks. It will return sane values for both 2.4 and 2.6 kernels. The patch I
submitted for 5.1 didn't return any values on 2.6 as "Mem:" and "Swap:" do not
exist in /proc/meminfo anymore - I didn't know it at the time though ;-)

Comment 3 Kaj J. Niemi 2004-03-17 21:53:36 UTC
Created attachment 98624 [details]
diff to net-snmp.spec version 5.1-11.1, might as well attach it now

Comment 4 Phil Knirsch 2004-03-18 16:37:16 UTC
Thanks Kaj!

I'll include your changes as soon as 5.1.1 goes final and will update
the rawhide version. Might be that it'll be too late for FC2, can't
tell yet, but we'll see :-)

Thanks for your updates, as always. :-)

Read ya, Phil

Comment 5 Kaj J. Niemi 2004-03-18 16:49:17 UTC
If it is too late for 5.1.1 in FC2 the hrstorage patch needs to be
patched against 5.1 otherwise it won't show up on 2.6 kernels.

Comment 6 Phil Knirsch 2004-03-18 16:54:10 UTC
Ah, because of /sys, right? I'll take a peek at it then tomorrow and
at least fix that patch.

Thanks,

Read ya, Phil

Comment 7 Kaj J. Niemi 2004-03-18 17:13:06 UTC
Created attachment 98656 [details]
Trivial backport of the 5.1.1rc1 hr_storage.c patch for net-snmp 5.1.

No.. /proc/meminfo is still there. I parsed the value of buffers from the line
starting "Mem:" (which doesn't exist on 2.6) instead of "Buffers:" (which does
exist on both 2.4 and 2.6) like I do in the patch attached to this bug..

Attached is a backport of the 5.1.1rc1 patch for 5.1. Hope it's okay to attach
here instead of opening a new bug.

Comment 8 Phil Knirsch 2004-03-23 15:40:01 UTC
OK, as net-snmp 5.1.1 is now out officially i'll update to that
version now and hope to get it into FC2. :-)

Read ya, Phil

Comment 9 Kaj J. Niemi 2004-03-23 15:57:45 UTC
Ok.. The earlier patches attached to this bug should apply cleanly to
it. Thanks.

Comment 10 Phil Knirsch 2004-04-08 14:45:41 UTC
Done.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.