Bug 118605 - redhat-artwork needs BuildRequires: kdelibs-devel
redhat-artwork needs BuildRequires: kdelibs-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 01:34 EST by John Thacker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 16:34:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2004-03-18 01:34:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
redhat-artwork attempts to build artwork for both KDE and GNOME.  It
has kdebase-devel as a BuildRequires, but it also needs kdelibs-devel
installed in order to build.  Without it, build fails with a missing
KDE headers message.

Version-Release number of selected component (if applicable):
redhat-artwork-0.93-1

How reproducible:
Always

Steps to Reproduce:
1. Make sure kdelibs-devel is not installed
2. rpmbuild --rebuild redhat-artwork-0.93-1.src.rpm
    

Actual Results:  Build fails.

Expected Results:  Build succeeds.

Additional info:
Comment 1 Alexander Larsson 2004-03-18 04:41:42 EST
Hmm. Shouldn't kdebase-devel require kdelibs-devel?
Comment 2 John Thacker 2004-03-18 07:42:20 EST
That's probably true; kdebase-devel should probably require
kdelibs-devel. That would also work.  Currently it doesn't require it,
though.
Comment 3 Alexander Larsson 2004-03-19 03:48:40 EST
kdebase-devel headers do include kdelibs-devel headers, so the
dependency should be there. When it is, redhat-artwork will work.
Reassigning.
Comment 4 John Thacker 2004-03-20 10:22:39 EST
The dependency should be there, but currently isn't:

[jat48@thacker jat48]$ rpm -q --requires kdebase-devel
kdebase = 6:3.2.1-1.4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Comment 5 Ngo Than 2004-03-22 16:34:32 EST
it's fixed in kdebase-3.2.1-1.5

Note You need to log in before you can comment on or make changes to this bug.