Bug 118657 - autofs can't handle ldap information for nfs mountpoints
autofs can't handle ldap information for nfs mountpoints
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 11:56 EST by joerg mauz
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 12:59:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joerg mauz 2004-03-18 11:56:14 EST
Description of problem:
when using ldap for distributung nfs mounts, autofs 4.1.0-2
will not be able to resolve the correct mount points and
therefore automountd can't handle these mount points.

here's my log from /var/log/mesages and my ldap 
server's  /var/log/slpad.log:

==> /var/log/slapd.log <==
Mar 18 16:44:09 theseus slapd[29091]: daemon: conn=103 fd=14 
connection from IP=192.168.15.11:40753 (IP=0.0.0.0:389) acc
epted.
Mar 18 16:44:09 theseus slapd[29091]: conn=103 op=0 BIND dn="" 
method=128
Mar 18 16:44:09 theseus slapd[29091]: conn=103 op=0 RESULT tag=97 
err=0 text=

==> /var/log/messages <==
Mar 18 16:44:09 theseus automount[30788]: using timeout 300 seconds; 
freq 75 secs
Mar 18 16:44:09 theseus automount[30788]: lookup(ldap): query failed 
for (&(objectclass=nisObject))
Mar 18 16:44:10 theseus automount[30788]: lookup(ldap): query failed 
for (&(objectclass=automount))
Mar 18 16:44:10 theseus automount[30788]: failed to load map, exiting
Mar 18 16:44:10 theseus automount[30788]: failed to remove dir 
`^W^E^H░^V]À^P: No such file or directory


as you can see in slapd.log there's >>> BIND dn="" <<< which normally
should be resolved/mapped to >>> 
dn="NISMAPNAME=AUTO.HOME,OU=SERVICES,DC=BL,DC=MAJOX,DC=DE" <<<

that's why automount can't load the maps tells "No such file or 
directory" referring to a file/dirname that seems to be real ugly
memory data 


Version-Release number of selected component (if applicable): 4.1.0-2


How reproducible:
1) install ldap server
2) create automount map entries within ldap server
3) try using these entries with installed autofs 4.1.0-2 



Workaround:
deinstall autofs 4.1.0-2 and install autofs-3.1.7-36 (is used the
rpm from redhat 9.0) and everything works fine...
Comment 1 Jeffrey Moyer 2004-03-22 12:59:57 EST
autofs-3.1.7-41 is the version of autofs that ships with RHEL 3.  We
do not support the two version of autofs you list in the bug report
under RHEL 3.

Having said that, at least one of the problems you mentioned is fixed
in autofs-4.1.1.  Namely, the garbage in the log file was due to an
errant use of a freed pointer.

Note You need to log in before you can comment on or make changes to this bug.