Bug 118712 - intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller sound outputs from MIC socket
intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller sound outputs from MIC s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 07:37 EST by Roger Nunn
Modified: 2008-10-10 15:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:54:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roger Nunn 2004-03-19 07:37:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a)
Gecko/20030728 Mozilla Firebird/0.6.1

Description of problem:
After configuring the Intel audio controller using redhat-config-soundcard
and checking that the following modules are installed (lsmod output):
i810_audio             28936   0  (autoclean)
ac97_codec             16104   0  (autoclean) [i810_audio]
soundcore               7044   2  (autoclean) [i810_audio]

The sound is outputed from the MIC socket on the sound card.
The sound is on-board, the motherboard is:
ASUS P4P800VM

the fingerprint for the intel audio card is:8086:24d5 (rev 02) 
Which maps to device:00:1f.5 Multimedia audio controller: Intel Corp.
82801EB AC'97 Audio Controller (rev 02)

Version-Release number of selected component (if applicable):
kernel-2.4.21-9.0.1EL

How reproducible:
Always

Steps to Reproduce:
1.Run redhat-config-soundcard on a system using the 82801EB sound
controller
2.play a test sound
(nothing is heard with the external speakers plugged into the speaker
jack)
3.plug the speakers into the MIC jack...test sound is heard


    

Actual Results:  No sound is heard with the speakers connected to the
speaker out jack

Expected Results:  sound is heard with speakers connected to the
correct output jack on the soundcard

Additional info:
Comment 1 John W. Linville 2004-07-06 13:08:27 EDT
Need output from the following command:

   dmesg | grep ^ac97_codec:

If nothing shows-up, try this:

   rmmod i810_audio ; rmmod ac97_codec
   modprobe i810_audio

Then, repeat dmesg command from above.

I suspect that this is related to Bug 109528...
Comment 2 John W. Linville 2004-10-12 16:06:59 EDT
Please reopen this bug if the combination of RHEL3 U4 and the
configuration changes described in Bug 109528 together don't fix this
problem.
Comment 3 Ernie Petrides 2004-10-12 18:54:08 EDT
Since RHEL3 U4 is not yet released (it's still in beta), I'm
putting this bug into MODIFIED state.  It will get closed
automatically by the Errata System when U4 is released.

We believe that the problem was resolved with the ac97 backport
that was committed to U4 in kernel versions 2.4.21-20.2.EL/-20.3.EL.
Comment 4 John Flanagan 2004-12-20 15:54:57 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.