Bug 118737 - showmount -e doesn't show every export (mountd?)
showmount -e doesn't show every export (mountd?)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-03-19 12:37 EST by Pancrazio `ezio' de Mauro
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 11:03:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pancrazio `ezio' de Mauro 2004-03-19 12:37:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7 StumbleUpon/1.89

Description of problem:
With the following /etc/exports:

/x           host1 host2 host3 @ng1

showmount -e shows:

Export list for localhost:

/x       @ng1,host2

i.e. host1 and host3 are missing from /usr2 (see below for netgroup
membership info)

With the following /etc/exports:

/x           host1 host2 host3 @ng2

showmount -e localhost shows:

/x       @ng2,host3,host2,host1

i.e. the output is correct

host1 is a member of @ng3 (not used above) and @ng3 is a member of @ng1
host2 is a member of @ng1
host3 is a member of @ng1 but not @ng2

Version-Release number of selected component (if applicable):
nfs-utils-1.0.5-3

How reproducible:
Always

Steps to Reproduce:
1. set up exports and neetgroups as above
2. restart nfs
3. run showmount -e
    

Actual Results:  See above

Expected Results:  See above

Additional info:
Comment 3 Chris Feist 2005-02-01 14:33:46 EST
It appears as though showmount (and the rpc.mountd daemon) are acting
appropriatly and not printing out duplicate names.

The line: 'host1 host2 host3 @ng1' is equivalent to 'host2 @ng1' if
host1 & host3 are members pf the @ng1 netgroup.

Unless there is any documentation that states otherwise, showmount is
doing the right thing by combining redundant entries.
Comment 4 Gary Mansell 2005-02-02 04:00:39 EST
I think that there still must be a further problem. I noticed that
showmount was not showing the correct output when using netgroups so I
changed my exports file to show 172.30.0.0/16(rw) so that my whole
site can mount the filesystem. When I ran showmount - it still came
back showing the netgroups and some indivual hosts. It was not until I
did a service nfs restart that the showmount -e then showed the
correct output.
Comment 5 Chris Feist 2005-02-02 16:00:10 EST
Do you run any commands after you edit the exports file?  Or did you
run the showmount directly after editing the exports file?
Comment 6 Gary Mansell 2005-02-03 03:55:27 EST
I tried both an exportfs -a and and exportfs -r but no joy
Comment 7 Chris Feist 2005-02-03 18:05:36 EST
Can you tell me which version of nfs-utils you are using and can you
show me the original /etc/exports line and the output from showmount
-e. as well as the new /etc/exports line and thet output from
showmount -e.

I'm still unable to replicate the problem.
Comment 8 Gary Mansell 2005-02-07 09:13:12 EST
Hi,

I can supply some but not all of the info requested:

[grma@dfgsrv 2] ~ > uname -a
Linux dfgsrv 2.4.21-9.0.1.ELsmp #1 SMP Mon Feb 9 22:26:51 EST 2004
i686 i686 i386 GNU/Linux

nfs-utils-1.0.6-33EL

Here is the details of the old exports file:
/usr2/apps addr:172.30.80.243(rw,no_root_squash)
whale(rw,no_root_squash) abbie(rw,no_root_squash) hinge(
rw,no_root_squash) bracket(rw,no_root_squash) emily(rw,no_root_squash)
angus(rw) @admin(rw,no_root_squash
) @cad(ro) @caeboys(ro) @caegirls(ro) @caecfd(ro) @indies(ro) @nvh(ro)
@softw(ro) @linux(ro) altix(rw,no_
root_squash) dfg(rw,no_root_squash) frink(rw,no_root_squash)
unwin(rw,no_root_squash) rembrandt(rw,no_roo
t_squash) nvhf(rw,no_root_squash) acq1(rw,no_root_squash)
/usr2/userdata addr:172.30.80.243(rw,no_root_squash)
@admin(rw,no_root_squash) @cad(rw) @caeboys(rw) @cae
girls(rw) @caecfd(rw) @indies(rw) @nvh(rw) @softw(rw) @linux(rw)
dfg(rw,no_root_squash)
/usr2/projdata addr:172.30.80.243(rw,no_root_squash)
indy3(rw,no_root_squash) acq2(rw,no_root_squash) nvh
h(rw,no_root_squash) @admin(rw,no_root_squash) @cad(rw) @caeboys(rw)
@caegirls(rw) @caecfd(rw) @indies(rw
) @nvh(rw) @softw(rw) @linux(rw) backup*(rw,no_root_squash)
dfg(rw,no_root_squash) nvhtape(rw,no_root_squ
ash) nvhsrv(rw,no_root_squash)  nvhi(rw,no_root_squash)
#/mnt/cdrom *(ro)


Here is the new exports file:

[grma@dfgsrv 6] ~ > more /etc/exports
/usr2/apps 172.30.0.0/16(ro) grma-lap(rw,no_root_squash)
chaos(rw,no_root_squash) sjmapc(rw,no_root_squas
h) unwin(rw,no_root_squash) whale(rw,no_root_squash) gazza(rw)
bruno(rw) raisa(rw) emily(rw) angus(rw)
/usr2/userdata 172.30.0.0/16(rw) grma-lap(rw,no_root_squash)
chaos(rw,no_root_squash) sjmapc(rw,no_root_s
quash)
/usr2/projdata 172.30.0.0/16(rw) grma-lap(rw,no_root_squash)
chaos(rw,no_root_squash) sjmapc(rw,no_root_s
quash) backup*(rw,no_root_squash) nvhtape(rw,no_root_squash)
nvhsrv(rw,no_root_squash) nvhi(rw,no_root_sq
uash)
#/mnt/cdrom *(ro)


I was having problems with the old exports file so I substituted the
new one, did an exportfs -r and and exportfs -a. When I then did a
showmount -e it would come back still showing the filesystems exported
to the netgroups and not using the new decimal IP information.

This is a live production server to several hundred people so I cannot
play with it to help more.
Comment 9 Chris Feist 2005-02-08 14:14:31 EST
Are you able to replicate the problem again?  Or did it only happen
once on your server?  If you can replicate it can you specify the
exact steps that you took.  Unfortunately I still haven't been able to
replicate the problem with my test machines.
Comment 10 Gary Mansell 2005-02-09 04:20:37 EST
As I mentioned before, unfortunately I cannot make changes to this
machine as it is a production server to several hundred nfs and smb
clients.
Comment 11 Chris Feist 2005-02-09 11:03:40 EST
If you see this problem again or are able to replicate it somewhere
else please open up a new bug (referencing this bug if possible).

I'm closing this bugzilla NOTABUG because the original issue was not a
bug.

Note You need to log in before you can comment on or make changes to this bug.