Bug 118756 - Writer - document format changes after yum update
Writer - document format changes after yum update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 15:56 EST by Robin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 11:30:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen capture of form before problem occurs. (108.86 KB, image/jpeg)
2004-03-29 13:07 EST, Robin
no flags Details
Screen capture after problem occurs. (110.16 KB, text/plain)
2004-03-29 13:09 EST, Robin
no flags Details

  None (edit)
Description Robin 2004-03-19 15:56:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
Before updating last week I used some templates that I have for
different forms.  Today I went to use the templates again and they
don't work.  The format of the document is severly changed and thus
they have to be re-editted before using.

Documents created from this template also have to be re-editted as
their format has changed.

I can only think that XFree86 font updates are what caused the
problem.  This should not occur and is a problem.  Problem doesn't
seem to be in Calc though.

XFree86-4.3.0-42 and fonts.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-6

How reproducible:
Always

Steps to Reproduce:
1. Open previously made form template.
2. Format has changed.
3.
    

Actual Results:  I have to reformat documents and templates before I
can use them.

Expected Results:  Documents and templates should not have changed.

Additional info:

Upgraded from RH8 to Fedora Core 1.  Had problems before but has been
working great since January.
Comment 1 Dan Williams 2004-03-19 16:15:49 EST
Could you clarify a few things?

1) What OOo version & Red Hat Linux version did you have _before_ your
yum upgrade?
2) What OOo version & Red Hat Linux/Fedora version do you have _now_?
3) Could you attach a sample template that no longer works?
4) Could you attach a sample of what it _should_ look like? (ie
screenshot or something)
5) What is the output of "rpm -qv XFree86" ?
Comment 2 Robin 2004-03-19 16:46:46 EST
1 - It was yum update for latest patches.
    I have been on fedora core since December, before Xmas.
2 - Just installed the updates (not all the latest updates).
3 - No I cannot.  It is an internal document.  Additional comments
4 - Again no.  Additiona comments.
5 - XFree86-4.3.0-42

Now for the fun part.  Additional comments.

I decided to logout and try in another account on this machine.  All
worked correctly on the other account with the same files.  I even
created a document using the templates and they were correct.

I then logged back into my normal account and tried everything and it
all worked well with both the new and old files.

What I see is there is some underlying problem that is causing
openoffice to view the documents as corrupt.  I was logged in from
07:00 to 14:00 so it could be related to some other problem.

Today I have only used mozilla-1.6-1.0.0 and gimp-1.2.5-1 before
opening Open Office.

This may have occured but I was in to much of a hurry as I have to get
these forms done within 10 minutes.

I will check next week at work if this problem occurs again and check
for other information when it occurs.  It is Friday and it is time to
go home and drink some beer. :)
Comment 3 Robin 2004-03-23 15:30:33 EST
It just occured again with one of the documents.

Applications running were Mozilla, The gimp, gnome-terminaland Open
Office.

Changes since Friday.  I have applied all the latest updates and
ensured that they are installed (I noticed that yum said some were
installed but weren't). 

gimp-1.2.5-1
XFree86-4.3.0-55
gnome-panel-2.4.2-3
gnome-terminal-2.4.0.1-1

I list gnome-panel as it was running at >90% in top while just sitting
and watching the readings and not dropping.

I killed gnome-panel and after it had restarted, the file still would
not load properly.  I then closed all applications and tried again. 
Still loading was not correct.
Closing XFree86 and startx again and the files loaded properly.  Now
is it a gnome, XFree86 or OOo problem?

I am trying to recreate all the details to see if I can find a point
of failure.

As soon as I find anything I will post details.
Comment 4 Robin 2004-03-25 16:30:26 EST
Well yesterday at 2 minutes before I had to leave work, the fault
occured again.  I could not find anything particular but I did confirm
that it is not related to gnome-panel as it was working as normal.

I killed every process started after Xclients in the process list
except fam.

Today I started Xwindows with xstart 2>xerror and I noticed as I open
OpenOffice I get this message.

Window manager warning: Property _NET_WM_NAME on window 0x2000020
contained invalid UTF-8
Window manager warning: Property _NET_WM_ICON_NAME on window 0x2000020
contained invalid UTF-8

This occurs on every window opened and every time I open an OOo
application.

Problem again today.
I have kept checking to see if I can find anything that I am doing
that causes the problem.
Now to read how I can increase debugging in XFree86.

Comment 5 Robin 2004-03-29 13:07:48 EST
Created attachment 98940 [details]
Screen capture of form before problem occurs.

This is a screen capture of the document before any problems on the system.
Comment 6 Robin 2004-03-29 13:09:18 EST
Created attachment 98941 [details]
Screen capture after problem occurs.

This is a screen capture of the problem.  It shows that the form format has
changed.
Comment 7 Caolan McNamara 2004-11-08 05:17:03 EST
caolanm->Robin.Laing: does this problem persist ?
Comment 8 Robin 2004-11-08 11:16:14 EST
I quit using the Fedora rpm of Open Office and all problems that I had
with FC and open office disappeared.  I have no problems with
templates or other graphics related problems.

As I don't use the FC version, I guess this issue can be closed as I
cannot submit any more information.
Comment 9 Caolan McNamara 2004-11-08 11:30:42 EST
A pity :-(

Note You need to log in before you can comment on or make changes to this bug.