Bug 118765 - anaconda installs wrong kernel on ia32e
anaconda installs wrong kernel on ia32e
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia32e Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 119019 119325 119656 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 18:00 EST by Jim Paradis
Modified: 2013-08-05 21:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 17:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Paradis 2004-03-19 18:00:47 EST
Description of problem: The installer installs both the SMP and UP
AMD64 kernels on ia32e systems.  This is incorrect; it should install
the single ia32e image on such systems.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. Install RHEL3 U2 on an ia32e system
2. Reboot after install finishes
3. System will crash on reboot
  
Actual results: The AMD64 kernels are installed on the ia32 system,
causing crash on boot


Expected results: The single ia32e kernel should be installed on an
ia32e system; this single image takes care of both UP and SMP.
Comment 1 Jeremy Katz 2004-03-22 00:41:22 EST
lwoodman told me this the other day and then didn't file it... fixed
in CVS, will be in the final U2 build.
Comment 2 Bill Nottingham 2004-03-23 17:25:14 EST
*** Bug 119019 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2004-03-29 10:34:33 EST
*** Bug 119325 has been marked as a duplicate of this bug. ***
Comment 4 Bill Peck 2004-03-29 10:43:11 EST
build from 0327.0 still shows the problem
Comment 5 Jeremy Katz 2004-04-02 18:20:16 EST
*** Bug 119656 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2004-04-06 20:08:34 EDT
bpeck -- I don't see this with re0330 in a quick test here.  If you
still see it with 0330 or later, let me know the machine
Comment 7 Suresh Siddha 2004-04-07 16:42:18 EDT
I installed re0330 on couple of different systems and I don't see 
this problem.
Comment 8 Bill Peck 2004-04-07 17:36:00 EDT
On the NEC mumble we have, it still installs the SMP kernel and when
it boots it panics. This is the same behaviour as the HP mumble.

On the Intel mumble it installs both but booting the smp kernel does
not cause the system to panic.

rpm -q --queryformat '%{arch}\n' kernel-smp kernel
x86_64
ia32e
Comment 9 Jeremy Katz 2004-04-11 14:10:53 EDT
Bill -- which tree are you installing from?
Comment 10 Bill Peck 2004-04-16 17:54:38 EDT
sorry - busy week trying to catch up...

re0415.0 is installing as we speak.. I'll update tomorrow
Comment 11 Bill Peck 2004-04-19 09:50:44 EDT
0415.1 does the same thing.  Installs both SMP and UP.  SMP is for
x86_64 and UP is for ia32e.  This is on Machine necmumble.lab
Comment 12 Jeremy Katz 2004-04-19 16:16:12 EDT
Hrmmm, doesn't happen on the DP box that lwoodman had (using 0416.1,
but should be no difference).  Can you get the nec box into the
installer for me to poke at at some point tomorrow?
Comment 13 Jeremy Katz 2004-06-09 17:27:57 EDT
This was pilot error (kernel-smp was explicitly requested in the ks.cfg)

Note You need to log in before you can comment on or make changes to this bug.