Bug 118776 - yum fails to satisfy dependencies for XFree86, even though already installed
yum fails to satisfy dependencies for XFree86, even though already installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 19:22 EST by Richard Lee
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-20 10:48:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Lee 2004-03-19 19:22:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
I am running "yum update" on a fresh fc2-test1 installation.  It
successfully downloads headers, but while trying to satisfy
dependencies, it fails with the error:

Package XFree86 needs XFree86-xfs = 4.3.0-45.0.1, this is not available.
Package XFree86 needs XFree86-libs = 4.3.0-45.0.1, this is not available.
Package XFree86-twm needs XFree86-libs = 4.3.0-45.0.1, this is not
available.
Package XFree86-devel needs XFree86-libs = 4.3.0-45.0.1, this is not 
available.

I have these versions already installed on my system, so not sure why
it thinks they are not available.  Running with the -d 10 flag, I get
the following near the end of the output:

debug dep: xorg-x11-libs req xorg-x11-libs-data -
0.0.6.6-0.0.2004_03_11.6 - 0
xorg-x11-libs wants
Fedora/RPMS/xorg-x11-libs-data-0.0.6.6-0.0.2004_03_11.6.i386.rpm
Best version for xorg-x11-libs-data is 0:0.0.6.6-0.0.2004_03_11.6
0, 0.0.6.6, 0.0.2004_03_11.6 vs 0, 0.0.6.6, 0.0.2004_03_11.6 = 0
i386
localhdrpath=
/var/cache/yum/development/headers/xorg-x11-libs-data-0-0.0.6.6-0.0.2004_03_11.6.i386.hdr
for xorg-x11-libs-data i386
bestarch = i386 for xorg-x11-libs-data
Got dep: xorg-x11-libs-data, i386
debug dep: XFree86 req XFree86-xfs - 4.3.0-45.0.1 - 0
No suggestion for XFree86 needing XFree86-xfs
Found some provides for XFree86-xfs
Cannot find a resolution attempting update out of loop on XFree86
debug dep: XFree86 req XFree86-libs - 4.3.0-45.0.1 - 0
No suggestion for XFree86 needing XFree86-libs
Found some provides for XFree86-libs
Cannot find a resolution attempting update out of loop on XFree86
debug dep: XFree86-twm req XFree86-libs - 4.3.0-45.0.1 - 0
No suggestion for XFree86-twm needing XFree86-libs
Found some provides for XFree86-libs
Cannot find a resolution attempting update out of loop on XFree86-twm
debug dep: XFree86-devel req XFree86-libs - 4.3.0-45.0.1 - 0
No suggestion for XFree86-devel needing XFree86-libs
Found some provides for XFree86-libs
Cannot find a resolution attempting update out of loop on XFree86-devel
Restarting Dependency Loop
.Package XFree86 needs XFree86-xfs = 4.3.0-45.0.1, this is not available.
Package XFree86 needs XFree86-libs = 4.3.0-45.0.1, this is not available.
Package XFree86-twm needs XFree86-libs = 4.3.0-45.0.1, this is not
available.
Package XFree86-devel needs XFree86-libs = 4.3.0-45.0.1, this is not
available.

Also, there are no headers in /var/cache/yum for XFree86.



Version-Release number of selected component (if applicable):
yum-2.0.6-1

How reproducible:
Always

Steps to Reproduce:
1. "yum update"
2.
3.
    

Actual Results:  Package XFree86 needs XFree86-xfs = 4.3.0-45.0.1,
this is not available.
Package XFree86 needs XFree86-libs = 4.3.0-45.0.1, this is not available.
Package XFree86-twm needs XFree86-libs = 4.3.0-45.0.1, this is not
available.
Package XFree86-devel needs XFree86-libs = 4.3.0-45.0.1, this is not
available.

Expected Results:  yum completes successfully, installing all packages
without dependency problems.

Additional info:
Comment 1 Jeff Johnson 2004-03-20 10:48:18 EST
These are package errors due to active development in rawhide.

Note You need to log in before you can comment on or make changes to this bug.