Bug 118783 - (USB SCSI)Remove USB device - while looking at it in Control Center - Crash
(USB SCSI)Remove USB device - while looking at it in Control Center - Crash
Status: CLOSED DUPLICATE of bug 121896
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-20 04:26 EST by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-03-20 04:26:01 EST
I was exploring - went to Control Center, scrolled to USB, saw
display, plugged in D-Link USB Bluetooth dongle, exited CC, restarted
CC, saw D-Link dongle parameters in CC USB display.

Then I pulled out the USB dongle (why not..) The display did not
update, the mouse froze - could not log in from another computer over
Telnet.

Did a power cycle to regain control..

-----
System is 'up2date -u' up to date (with 2.6.3.. kernel - highest
number in up2date system).

Dual 2.4ghz Xeon w 1GB memory.
Comment 1 Bob Gustafson 2004-03-21 02:04:34 EST
I did a bit more testing.

The crash does not have anything to do with Control Center.

I inserted the Bluetooth Dongle in a USB hole, the power LED on the
dongle lit up (as before).

I looked at the dongle using Control Center, but then totally (?)
exited from Control Center.

System was running fine.

Pulled Dongle out of USB hole.

System hung hard. Mouse froze, no blinking lights anywhere.

Power cycle to restart.

----------

Let me know what further tests I can do.
Comment 2 Bob Gustafson 2004-03-21 11:34:22 EST
I also have a Keyspan USB Serial Adapter.

I plugged this in and pulled it out and thre were no problems.

I checked for the appearance of the device in the Control Center USB
devices display and everything looked good. Plug it in, device
description appears. Unplug it and description goes away (but I have
to select another screen in Control Center and then go back to USB to
refresh the information.

No crash with the Keyspan USB Serial Adapter plug/unplug.[user1@hoho2

Looks like the previous crash might be more related to Bluetooth. 

This is my kernel version:

user1]$ cat /proc/version
Linux version 2.6.3-2.1.253.2.1smp (bhcompile@tweety.devel.redhat.com)
(gcc version 3.3.3 20040216 (Red Hat Linux 3.3.3-2.1)) #1 SMP Fri Mar
12 14:23:36 EST 2004
[user1@hoho2 user1]$
Comment 3 Jonathan Blandford 2004-03-21 21:42:31 EST
reassigning.
Comment 4 Nils Philippsen 2004-03-23 09:23:40 EST
Similar here, only that I don't have an external dongle but an
internal one in the laptop (Dell D800). Enabling/disabling it with
Fn+F2 also hangs the machine.
Comment 5 Nils Philippsen 2004-03-23 09:24:31 EST
Forgot: kernel-2.6.3-2.1.253.2.1
Comment 6 Bob Gustafson 2004-05-08 18:37:55 EDT

*** This bug has been marked as a duplicate of 121896 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.