Bug 118794 - new_allocator.h buglet (allocator should be std::allocator?)
Summary: new_allocator.h buglet (allocator should be std::allocator?)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc34 (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-20 13:17 UTC by Neal Becker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 3.4.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 12:20:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal Becker 2004-03-20 13:17:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
//using namespace std;
#include "demangle.h"
g++34 -c Test.cc
In file included from demangle.h:40,
                 from Test.cc:2:
/usr/lib/gcc/i386-redhat-linux/3.4.0/../../../../include/c++/3.4.0/ext/new_allocator.h:80: error: `allocator' has not been declared
/usr/lib/gcc/i386-redhat-linux/3.4.0/../../../../include/c++/3.4.0/ext/new_allocator.h:80: error: expected `,' or `...' before '<' token

I think the problem is in ext/new_allocator.h allocator should be std::allocator.  Possible need include to declare this also.

Version-Release number of selected component (if applicable):
gcc34-3.4.0-0.7

How reproducible:
Always

Steps to Reproduce:
1.above
2.
3.
    

Additional info:

Comment 1 Jakub Jelinek 2004-03-22 17:19:00 UTC
This has been already fixed in CVS on gcc-3_4-branch and will show up
as soon as next gcc34 rpms will be made.

Comment 2 Jakub Jelinek 2004-05-27 12:20:02 UTC
Seems to work for me in libstdc++34-devel-3.4.0-1.


Note You need to log in before you can comment on or make changes to this bug.