Bug 118812 - Configuration capabilities are inflexible and limited
Configuration capabilities are inflexible and limited
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-bind (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-20 16:58 EST by Dan Thurman
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Thurman 2004-03-20 16:58:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20020830

Description of problem:
The DNS configuration tool is limited and does not allow for manual
named entries where needed such as a wilcard A record. Manual entries
are blown away.

Version-Release number of selected component (if applicable):
redhat-config-bind-1.8.1-18

How reproducible:
Always

Steps to Reproduce:

1) There is no ability to insert wildcard A records for cases where
virtual pages are involved.  The insertion of the wildcards '*' is not
permitted in the textbox.  Manually adding the wildcard A record will
be blown away by the tool as it does not recognize manual additions.

Example:
*.autodice.com. IN A    xxx.xxx.xxx.xxx  <== cannot add via DNS Tool


2) Entries manaully added to the /etc/named.custom file does *not*
appear in the DNS tool.  Why?  These were manually added because
again, there was no ability for me to add an extra line:

Example: 
zone "xxxx.com" {
 type master;
 file "xxxx.com.zone";
 allow-transfer { xxx.xxx.xxx.xx1; };  <== cannot add via DNS Tool
};

Fortunately, manually adding this was preserved and not blown away by
the DNS tool.
    

Actual Results:  1) DNS Tool blows away manual settings in the ZONE files
2) DNS Tool does not blow manual settings in the named.custom file

Expected Results:  1) Manual additions to the zone or other related
files should be preserved if the tool itself cannot add it itself or
otherwise there should be a file for manual addtitions so that the
tool will add them in.

Additional info:
Comment 1 Daniel Walsh 2004-03-25 16:34:37 EST
Please check out system-config-bind from rawhide.

Dan
Comment 2 Jay Turner 2004-09-02 01:08:19 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-364.html

Note You need to log in before you can comment on or make changes to this bug.