Bug 118835 - mozilla crashes when java applet
mozilla crashes when java applet
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
http://www.fourmilab.ch/gravitation/o...
: FutureFeature
: 118836 (view as bug list)
Depends On: 109791
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-21 06:18 EST by Landon Curt Noll
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 19:12:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updates that WS Beta and WS Extra Beta would apply (5.44 KB, text/plain)
2004-04-13 17:37 EDT, Landon Curt Noll
no flags Details

  None (edit)
Description Landon Curt Noll 2004-03-21 06:18:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; , en_US.UTF-8, en_US, en)

Description of problem:
When mozilla is given this URL:

	http://www.fourmilab.ch/gravitation/orbits/

it immediately crashes.

FYI: My RHEL3 has installed:

mozilla-nss-1.4-3.0.18
mozilla-js-debugger-1.4-3.0.18
mozilla-1.4-3.0.18
mozilla-chat-1.4-3.0.18
mozilla-psm-1.4-3.0.18
mozilla-nspr-1.4-3.0.18
mozilla-dom-inspector-1.4-3.0.18
mozilla-mail-1.4-3.0.18
IBMJava2-JRE-1.4.1-11

And I installed the Java plugin by doing:

cp /opt/IBMJava2-141/jre/bin/libjavaplugin_ojigcc3.so /usr/lib/mozilla/plugins

Mozilla also crashes immediately when it accesses any
web page (most of them have java applets) on a
TrueTime / Symmetricom TimeVault NTP clock.


Version-Release number of selected component (if applicable):
mozilla-1.4-3.0.18.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.install the Java Plugin
cp /opt/IBMJava2-141/jre/bin/libjavaplugin_ojigcc3.so /usr/lib/mozilla/plugins
2.mozilla http://www.fourmilab.ch/gravitation/orbits/
3.mozilla http://~~~some TimeVault Host~~~/
    

Actual Results:  Mozilla crashes almost immediately

Expected Results:  The Orbits in Strongly Curved Spacetime applet runs.
The TrueTime web page displays with the TimeVault clock status

Additional info:
Comment 2 Suzanne Hillman 2004-03-26 12:01:05 EST
Did you try linking, instead of copying, the file in question? What
instructions did you follow to install the plugin?
Comment 3 Landon Curt Noll 2004-03-26 13:29:39 EST
> Did you try linking, instead of copying, the file in question? 
 
Sorry, I should have said that I also tried the symlink method 
when I first reported this bug.  Using a symlink: 
 
    ln -s /opt/IBMJava2-141/jre/bin/libjavaplugin_ojigcc3.so \ 
	/usr/lib/mozilla/plugins/libjavaplugin_ojigcc3.so 
 
When this happens, Mozilla hangs and a java process: 
 
	java -Dmozilla.workaround=true 
-Xbootclasspath/a:/opt/IBMJava2-141/jre/lib/javaplugin.jar 
-Djavaplugin.lib=/opt/IBMJava2-141/jre/bin/libjavaplugin_jnigcc3.so 
-Djavaplugin.nodotversion=141 -Djavaplugin.version=1.4.1 
-DtrustProxy=true -Xverify:remote 
-Djava.class.path=/opt/IBMJava2-141/jre/lib/applet 
sun.plugin.navig.motif.Plugin 
 
gets stuck in a CPU burning loop (taking ~90% of the CPU). 
An strace of this process shows that it is an a loop doing: 
brk(0)                                  = 0xffef000 
brk(0x10010000)                         = 0xffef000 
mmap2(NULL, 1048576, PROT_READ|PROT_WRITE, 
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = -1 ENOMEM (Cannot allocate 
memory) 
mmap2(NULL, 2097152, PROT_NONE, 
MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot 
allocate memory) 
mmap2(NULL, 1048576, PROT_NONE, 
MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot 
allocate memory) 
mmap2(NULL, 2097152, PROT_NONE, 
MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot 
allocate memory) 
mmap2(NULL, 1048576, PROT_NONE, 
MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot 
allocate memory) 
rt_sigprocmask(SIG_SETMASK, NULL, ~[KILL USR2 STOP RTMIN], 8) = 0 
rt_sigprocmask(SIG_SETMASK, ~[KILL USR2 STOP RTMIN], NULL, 8) = 0 
rt_sigprocmask(SIG_SETMASK, ~[KILL USR2 STOP RTMIN], NULL, 8) = 0 
rt_sigreturn(0x40186e58)                = 536873000 
--- SIGSEGV (Segmentation fault) @ 0 (0) --- 
 
over and over again. 
 
BTW: See bug #118836 for a similar SIGSEGV loop. 
 
> What instructions did you follow to install the plugin? 
 
file:/opt/IBMJava2-141/docs/jre/runtimeguide.lnxia32.en.htm#wq79 
 
BTW: I also tried: 
 
file:/opt/IBMJava2-141/docs/jre/runtimeguide.lnxia32.en.htm#wq72 
 
but that failed to install any plugin. 
 
     
Comment 5 Karl Latiss 2004-04-05 01:56:49 EDT
This appears to be the case with the latest mozilla errata as well
(1.4.2).

Interestingly when I compiled galeon 1.3.10 based on the previous RH
mozilla issue there was no problem. Perhaps it's compiler related?
Comment 6 Thomas Fitzsimmons 2004-04-05 14:49:16 EDT
This may be fixed by the new Java packages we'll ship with RHEL3 U2.

In the meantime, a few questions:

1) What architecture are you using?  I'm assuming it's x86 and not x86-64?

2) Do only the applets you've listed crash the browser?  Or does any
Java applet cause a crash?

Just to confirm, you definitely can't copy the plugin .so.

ln -s /opt/IBMJava2-141/jre/bin/libjavaplugin_ojigcc3.so \ 
	/usr/lib/mozilla/plugins/libjavaplugin_ojigcc3.so 

is the right thing to do, because the .so must be loaded from within
the Java directory structure (so that it can find other VM-related files.
Comment 7 Thomas Fitzsimmons 2004-04-05 16:01:39 EDT
*** Bug 118836 has been marked as a duplicate of this bug. ***
Comment 8 Landon Curt Noll 2004-04-05 16:14:59 EDT
> 1) What architecture are you using?  I'm assuming it's x86 and not  
x86-64?  
  
It is x86.  AMD i686 Athlon to be more precise.  It is NOT x86-64.  
  
> 2) Do only the applets you've listed crash the browser?  Or does  
any  
> Java applet cause a crash?  
  
It seems that any Java applet will cause a crash.  For example  
I tried several under http://java.sun.com/applets/.  Each time  
the java process went into a CPU burning loop like the one  
shown in Comment #3.  The two applets discussed in comment #1  
are straight forward applets that do nothing fancy, which is  
why I used them as bug report examples.  
  
If there is another specific URL you would like me to test, let  
me know.  I believe that nearly any, if not any applet will cause  
this problem.  
  
> Just to confirm, you definitely can't copy the plugin .so  
  
I am using the symlink method to test.  My "cp" in step #2 in  
Comment #1 should have been "ln -s".  Yes, copying the .so  
doesn't work.  The symlink method:  
  
	ln -s /opt/IBMJava2-141/jre/bin/libjavaplugin_ojigcc3.so  
/usr/lib/mozilla/plugins/  
  
while the correct thing to do, causes the CPU burning hang / crash.  
Comment 9 Landon Curt Noll 2004-04-05 16:19:47 EDT
> This may be fixed by the new Java packages we'll ship with RHEL3 
U2. 
 
If you give me a URL of the RPMs (I'm assuming IBMJava2-JRE 
and IBMJava2-SDK updates?), I'll be happpy test them. 
  
Comment 10 Thomas Fitzsimmons 2004-04-05 18:22:19 EDT
You should be able to pull the java-1.4.1-ibm and
java-1.4.1-ibm-plugin packages from the RHEL3 U2 RHN channel.

You'll probably have to remove all remnants of libjavaplugin* from
/usr/lib/mozilla/plugins before installing the -plugin package.
Comment 11 Thomas Fitzsimmons 2004-04-05 18:23:16 EDT
Err, that should be "the RHEL3 U2 Beta RHN channel."
Comment 12 Landon Curt Noll 2004-04-05 22:42:30 EDT
In Comment #11 you said "RHEL3 U2 RHN channel".  I went to my RHN 
'view all available software channels' link: 
 
	https://rhn.redhat.com/network/software/all_channels.pxt 
 
and did not see that channel. 
 
I tried a few channels that might have been close such as the 
rhel-i386-ws-3-beta channel.  It did not have any such 
'java-1.4.1-ibm*' package that I could find. 
 
I also did a RHN package search under: 
 
	https://rhn.redhat.com/network/software/search.pxt 
 
for 'java' in "name and Summary" for the IA-32 arch and did not 
see the 'java-1.4.1-ibm*' packages. 
 
Do I/general folks have access to the "RHEL3 U2 RHN" channel 
right now? 
 
Please advise. 
 
Comment 13 Thomas Fitzsimmons 2004-04-13 11:43:01 EDT
See:

http://www.redhat.com/archives/taroon-beta-list/2004-April/msg00000.html

for the release announcement.  I think my suggestion was a day early.
 You should be able to pull the packages now.
Comment 14 Landon Curt Noll 2004-04-13 17:14:20 EDT
I subscribed to Red Hat Enterprise Linux WS (v. 3 for x86) Beta. 
This package does not contain a java-1.4.1-ibm RPM, not does it 
contain a java-1.4.1-ibm-plugin RPM.  It does contail the 
IBMJava2-JRE-1.4.1-11 and IBMJava2-SDK-1.4.1-11 RPMs which is 
what I have been using all along AND which is broken as per 
comment #3.  It appears that this issue is not fixed in 
Red Hat Enterprise Linux WS (v. 3 for x86) Beta. 
 
Is there somewhere else from which I could test java-1.4.1-ibm 
and java-1.4.1-ibm-plugin?   
Comment 15 Landon Curt Noll 2004-04-13 17:37:18 EDT
Created attachment 99386 [details]
updates that WS Beta and WS Extra Beta would apply 

I subscribed to Red Hat Enterprise Linux WS (v. 3 for x86) Beta and
Red Hat Enterprise Linux WS (v. 3 for x86) Extras Beta (just in case).
I saw no java-1.4.1-ibm java-1.4.1-ibm-plugin RPMs.  The old IBMJava2-JRE
and IBMJava2-SDK were not downloaded because I already have them (this
bug is filed against those IBMJava2 packages BTW).

Also FYI: A full up2date of these Beta channels download fails because:

The package GConf2-2.2.1-4 is signed, but with an uknown GPG key. Aborting...
Package GConf2-2.2.1-4 has a unknown GPG signature.
Comment 16 Landon Curt Noll 2004-04-14 16:16:10 EDT
OK, I forgot that I needed the BETA GPG key, so ignoring the 
"A full up2date of these Beta channels download fails because" 
remark in comment #15: 
 
I still cannot find any channel from which java-1.4.1-ibm 
and java-1.4.1-ibm-plugin RPMs can be downloaded. 
 
Can you supply a URL to some place where they may be found? 
Comment 17 Thomas Fitzsimmons 2004-04-14 17:45:24 EDT
I expected the packages to be in this channel:

rhel-i386-as-3-extras-beta               Red Hat Enterprise Linux AS
(v. 3 for x86) Extras Beta

Apparently they may have been held back for some reason.  I'm
investigating now.
Comment 18 Thomas Fitzsimmons 2004-04-14 18:34:21 EDT
All of the LACD update packages have been held back because
redistribution agreements are not in place for a few of them (on x86
and x86-64).

I'll keep you posted as I get more information.
Comment 19 Thomas Fitzsimmons 2004-04-20 11:40:00 EDT
The java-1.4.1-ibm packages should now be available on the
rhel-i386-as-3-extras-beta channel.
Comment 20 Landon Curt Noll 2004-04-20 22:11:49 EDT
FYI: The java-1.4.1-ibm-1.4.1.2-1jpp_2rh.i386.rpm and 
java-1.4.1-ibm-plugin-1.4.1.2-1jpp_2rh.i386.rpm RPMs were found 
in the Red Hat Enterprise Linux WS (v. 3 for x86) Extras Beta 
channel (Label: rhel-i386-ws-3-extras-beta).  These packages 
required jpackage-utils-1.5.33-1jpp_4rh.noarch.rpm which was found 
in the Red Hat Enterprise Linux WS (v. 3 for x86) Beta 
channel (Label: rhel-i386-ws-3-beta). 
 
Just to start with a clean slate, I did a: 
 
rpm -e IBMJava2-JRE-1.4.1-11 IBMJava2-SDK-1.4.1-11 
rm -f /etc/sysconfig/java.rpmsave 
 
before I did a: 
 
rpm -ivh jpackage-utils*.rpm java-*.rpm 
 
The java-1.4.1-ibm-plugin did not come with any specific 
documentation, so I'll guess that one needs to symlink 
the libjavaplugin_ojigcc3.so into the mozilla plugin area: 
 
ln -s 
/usr/lib/jvm/java-1.4.1-ibm-1.4.1.2/jre/bin/libjavaplugin_ojigcc3.so  
/usr/lib/mozilla/plugins/libjavaplugin_ojigcc3.so 
 
NOTE: The java-1.4.1-ibm-plugin RPM should have a README under, 
say, /usr/share/doc explaining what needs to be done to get 
the plugin working for Mozilla, Netscape and Konqueror. 
I recommend making this change before the final release. 
 
The result of all of the above is that Mozilla works on: 
 
	http://www.fourmilab.ch/gravitation/orbits/ 
 
	(try it!  :-) 
 
The TrueTime / Symmetricom TimeVault NTP clock Java pages 
do not successfully load, however. 
 
For Konqueror, I did a Settings ==> Configure Konqueror ==> 
Java * JavaScript ==> Path to Java executable ==> /usr/bin/java 
then OK.  This allowed Konqueror to work on the same 
gravitation orbits Java web site. 
 
For Konqueror, the TrueTime / Symmetricom TimeVault NTP clock 
Java pages work much better. 
 
I suspect there is some problem with Mozilla and the Java from 
a TrueTime / Symmetricom TimeVault NTP clock.  Konqueror loads 
the applet / Botton controls OK while Mozilla does not. 
 
Overall, this is a big improvement even if there may be 
some Mozilla Java issues. 
Comment 21 Thomas Fitzsimmons 2004-04-21 09:22:57 EDT
You shouldn't need to manually create the symlink in
/usr/lib/mozilla/plugins.  One of the improvements in the new Java
packages is that plugin installation should work "out-of-the-box". 
Did the plugin not work upon initial installation of the RPMs?

Thanks for the Konqueror instructions.  They probably won't make it
into the final release this time, but I'll put a README in subsequent
updates.

If the TrueTime applet works in Konqueror but not in Mozilla, then it
would appear that this is a Mozilla problem.  Could you file another
bug for this?
Comment 22 Landon Curt Noll 2004-04-21 15:24:15 EDT
> You shouldn't need to manually create the symlink in ... 
 
You are correct.  When I removed the symlink, Mozilla still 
had the java plugins. 
 
> Did the plugin not work upon initial installation of the RPMs? 
 
I suspect we had a Mozilla already running.  I suspect we might 
have restarted it after the symlink setup.  The "out-of-the-box" 
experience seems to work for Mozilla. 
 
> Thanks for the Konqueror instructions.  They probably won't make 
> it into the final release this time, but I'll put a README in 
> subsequent updates. 
 
Should a subsequent release have an "out-of-the-box" experience 
similar to that of Mozilla?  I.e., perhaps the subsequent release 
should "just work" for Konqueror like it does for Mozilla? 
 
Maybe an enhancement bug for Konqueror is needed? 
 
> If the TrueTime applet works in Konqueror but not in Mozilla, then  
> it would appear that this is a Mozilla problem.  Could you file 
> another bug for this? 
 
Should this bug be filed under Mozilla, or the java-* rpm or 
some other component? 
Comment 23 Thomas Fitzsimmons 2004-09-21 19:12:00 EDT
I re-tested the fourmilab page with mozilla-1.4.2-3.0.2 and
java-1.4.2-ibm-plugin-1.4.2.0-1jpp_8rh and it works fine.  Closing.


Note You need to log in before you can comment on or make changes to this bug.