Bug 118836 - konqueror never finishes loading java applets
konqueror never finishes loading java applets
Status: CLOSED DUPLICATE of bug 118835
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
Ben Levenson
http://www.fourmilab.ch/gravitation/o...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-21 06:36 EST by Landon Curt Noll
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2004-03-21 06:36:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; , en_US.UTF-8, en_US, en)

Description of problem:
When konqueror is given this URL:

	 http://www.fourmilab.ch/gravitation/orbits/

it never finishes loading.

FYI: My RHEL3 has installed:

kdebase-3.1.3-5.2
IBMJava2-JRE-1.4.1-11

I went to the Konqueror->Settings->Configure Konqueror
->Java & JavaScript

I Enabled Java for the given page (or just Enabled Java globally)
and set the "Path to Java executable, or 'java':" to

	/opt/IBMJava2-141/bin/java

A ps will show that the java program is running in the background as:

/opt/IBMJava2-141/bin/java -classpath /usr/share/apps/kjava/kjava.jar -Djava.security.manager=org.kde.kjas.server.KJASSecurityManager -Djava.security.policy=/usr/share/apps/kjava/kjava.policy org.kde.kjas.server.Main

A strace of the process shows that it is in a loop of:

brk(0)                                  = 0xffef000
brk(0x10010000)                         = 0xffef000
mmap2(NULL, 1048576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = -1 ENOMEM (Cannot allocate memory)
mmap2(NULL, 2097152, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot allocate memory)
mmap2(NULL, 1048576, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot allocate memory)
mmap2(NULL, 2097152, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot allocate memory)
mmap2(NULL, 1048576, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = -1 ENOMEM (Cannot allocate memory)
rt_sigprocmask(SIG_SETMASK, NULL, ~[KILL USR2 STOP RTMIN], 8) = 0
rt_sigprocmask(SIG_SETMASK, ~[KILL USR2 STOP RTMIN], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, ~[KILL USR2 STOP RTMIN], NULL, 8) = 0
rt_sigreturn(0x40186e58)                = 536873000
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

Konqueror also hangs when it accesses any
web page (most of them have java applets) on a
TrueTime / Symmetricom TimeVault NTP clock.

Version-Release number of selected component (if applicable):
kdebase-3.1.3-5.2

How reproducible:
Always

Steps to Reproduce:
1.Configure Konqueror to use the java executable:
/opt/IBMJava2-141/bin/java
2.Access the URL: http://www.fourmilab.ch/gravitation/orbits/
3.Access a web page on a TrueTime / Symmetricom TimeVault NTP clock
(most have some sort of Java applet)
    

Actual Results:  Konqueror fails to load the applet and the java executable
burns CPU time.

Expected Results:  The Orbits in Strongly Curved Spacetime applet runs.
The TrueTime web page displays with the TimeVault clock status.

Additional info:
Comment 2 Thomas Fitzsimmons 2004-04-05 16:01:37 EDT

*** This bug has been marked as a duplicate of 118835 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.