Bug 118903 - ca-bundle.crt in openssl should be a config file
ca-bundle.crt in openssl should be a config file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 12:08 EST by Orion Poplawski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: openssl-0.9.7f-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 06:26:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2004-03-22 12:08:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
I have set up my own CA for internal use and need to add my CA key to
ca-bundle.crt so our clients can connect properly.  However, upgrading
openssl will wipe out or CA key from ca-bundle.crt because it is not a
config file.

I suggest either making ca-bundle.crt a config file or providing some
other way to include local CA certs.

Version-Release number of selected component (if applicable):
openssl-0.9.7a-34

How reproducible:
Always

Steps to Reproduce:
1.Add a cert to ca-bundle.crt
2.Upgrade (rpm -U) openssl
3.
    

Additional info:

Note You need to log in before you can comment on or make changes to this bug.