This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11893 - Routing table is emptied after use of linuxconf
Routing table is emptied after use of linuxconf
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-04 01:39 EDT by monica
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description monica 2000-06-04 01:39:46 EDT
Every time I use Linuxconf to edit any parameter, my routing table is 
EMPTIED, with the exception of the localhost.  I then lose all network and 
internet connectivity, and it is impossible to add the default gateway  
route via "route add default gw xxx.xxx.xx.x".  It will not accept any 
entries, returning the error "SIOCADDRT: Network is unreachable".  From 
what I've been able to discern, this error means you need to add the 
default gateway to your routing table, which it will not accept. The only 
solution I have found is to use netconfig.  HOWEVER, watch out because the 
default gateway and nameserver was auto-filled incorrectly each time I 
used this utility!  The broadcast address was auto-filled as the default 
gateway and my IP address as the nameserver.
Comment 1 Brent Fox 2002-06-05 12:18:44 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:47:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.