Bug 118958 - ls -l in Japanese environment is not correct
ls -l in Japanese environment is not correct
Status: CLOSED DUPLICATE of bug 124862
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 03:22 EST by Nakai
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 12:27:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
actual result (1.29 KB, image/png)
2004-11-08 00:16 EST, Nakai
no flags Details
The expected result (8.20 KB, image/png)
2004-11-08 00:18 EST, Nakai
no flags Details

  None (edit)
Description Nakai 2004-03-23 03:22:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6) Gecko/20040115

Description of problem:
ls -l returns wrong string in Japanese locale.

LANG=ja_JP.UTF-8 ls -l
drwxrwxr-x  2 nakai nakai     4096  3月  8 20:39 CVS


Version-Release number of selected component (if applicable):
coreutils-5.0-39

How reproducible:
Always

Steps to Reproduce:
1. LANG=ja_JP.UTF-8
2. ls -l
3. Linux OS is crappy
    

Actual Results:  drwxrwxr-x  2 nakai nakai     4096  3月  8
20:39 CVS


Expected Results:  drwxrwxr-x  2 nakai nakai     4096  3月 
8日 20:39 CVS


Additional info:

No such laughs in the proprietary.
Comment 1 Tim Waugh 2004-03-23 05:59:06 EST
coreutils-5.0-39?  Could you try the current version, 5.2.1-3, please?

Also, I've no idea how to try to reproduce the bytes above since I
don't know the date of the file. :-)

Please could you give me something repeatable, like this?:

touch -d "Jan 1 2004" foo
ls -l foo

with either a screenshot, or a dump of the bytes with 'od -tx1'?  Thanks.
Comment 2 Nakai 2004-11-08 00:15:23 EST
Still happens on coreutils-5.2.1-31.
Comment 3 Nakai 2004-11-08 00:16:02 EST
Created attachment 106268 [details]
actual result
Comment 4 Nakai 2004-11-08 00:18:22 EST
Created attachment 106269 [details]
The expected result
Comment 5 Tim Waugh 2004-11-09 12:27:56 EST

*** This bug has been marked as a duplicate of 124862 ***

Note You need to log in before you can comment on or make changes to this bug.