Bug 118963 - [PATCH] bug fix in statfs support
[PATCH] bug fix in statfs support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ia32el (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 04:32 EST by Yoav Zach
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 14:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the statfs problem (3.07 KB, patch)
2004-03-23 04:34 EST, Yoav Zach
no flags Details | Diff
test case for reproducing the problem with statfs (1.26 KB, text/plain)
2004-03-23 04:36 EST, Yoav Zach
no flags Details
libiai32toia64.so binary (152.41 KB, application/octet-stream)
2004-03-23 04:38 EST, Yoav Zach
no flags Details
Updated patch against build 4588 (3.23 KB, patch)
2004-03-26 19:46 EST, Arun Sharma
no flags Details | Diff

  None (edit)
Description Yoav Zach 2004-03-23 04:32:25 EST
Description of problem:
in the support for statfs 32 bit syscalls, the EL does not copy the 
f_spare fields back to the user.

Version-Release number of selected component (if applicable):


How reproducible:
Please see the attached test case.

Steps to Reproduce:
1. build and run the attached test case
2. check the output 
3.
  
Actual results:
f_spare[0] = 20000001

Expected results:
f_spare[0] = 0

Additional info:
The problem is in libia32toia64.so. Attached please find a patch to 
fix this issue, and a new binary that was built with this patch.
Comment 1 Yoav Zach 2004-03-23 04:34:20 EST
Created attachment 98773 [details]
patch to fix the statfs problem

this is a patch to the sources of libia32toia64.so
Comment 2 Yoav Zach 2004-03-23 04:36:34 EST
Created attachment 98774 [details]
test case for reproducing the problem with statfs

please build and run this test with an existing file-system as argument. e.g.
-"./fstatfs /home".
Comment 3 Yoav Zach 2004-03-23 04:38:30 EST
Created attachment 98775 [details]
libiai32toia64.so binary

this is a new version of libia32toia64.so, includes the patch that fixes the
statfs problem.
Comment 4 Jakub Jelinek 2004-03-25 17:06:10 EST
I see your patch is changing build number for 4592 to 4593, but
our src.rpm has build 4588.  Are the 4588 .. 4592 differences
unimportant?
Comment 5 Tony Luck 2004-03-26 14:21:08 EST
Comment from Israel team:

We recommend to take the latest version 4593 – which includes also 
the Veritas bug fix which is a high priority for them. We are  
applying full validation cycle to this version same as we did to the 
previous release candidate – and its stability is better. Full list 
of changes will be supplied early next week. 

It is important that this updated version of IA32-EL make it onto the 
3/31 beta release of update2.
Comment 6 Jakub Jelinek 2004-03-26 14:27:32 EST
Are the 4593 sources publically available (if so where) or can you attach them here (if not)?
Comment 7 Arun Sharma 2004-03-26 19:46:15 EST
Created attachment 98895 [details]
Updated patch against build 4588


This one applies cleanly.
Comment 8 Larry Troan 2004-03-29 08:13:19 EST
FROM ISSUE TRACKER
Event posted 03-26-2004 08:20pm by tonyluck with duration of 0.00  	
To be a bit more specific about "some customers" ... the issue here is
a file system that supports snapshot mounts, and returns data about
the snapshot mount in the f_spare[] fields of the statfs structure. 
Without this data, all the maintenance tools for snapshot mounts fail,
so this critical feature is useless.

------------
Event posted 03-29-2004 02:33am by arjanv with duration of 0.00 	
which filesystem is this ?
Comment 9 Larry Troan 2004-03-29 08:16:21 EST
ISSUE TRACKER 36466 OPENED AS SEV 1

Note that depending on answer to fs question above, may be bug or
feature request (to support "shapshot"). 
Comment 10 Larry Troan 2004-03-29 08:20:02 EST
Also, believe Version in this Bug should be "RHEL3-update" and from
Summary line that Platform in Bug should be "all" to reflect x86 and
ia64. Is it also a problem on x86_64?
Comment 11 Larry Troan 2004-03-29 08:25:11 EST
Sorry, platform is ia64 and bug relates to "emulation layer". 
Comment 13 Yoav Zach 2004-04-14 07:11:19 EDT
The version of libia32toia64.so remained 4588, as before the fix, 
while it should have changed to 4593. This is not right - it may lead 
to confusion with versions, which will make customer support more 
difficult.
You can see the version of libia32toia64.so by running libia32x.so 
with '-v' switch.
The patch that Arun sent changes the Makefile of ia32toia64 so that 
the version changes. Apparently, the patch was not applied fully.

Note You need to log in before you can comment on or make changes to this bug.